signed.applets.codebase_principal_support messing with local settings

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: postnalista, Assigned: stransky)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.5) Gecko/20120606 Firefox/10.0.5
Build ID: 20120606062003

Steps to reproduce:

i set:
// Allow the hosts below to execute privileged script without warnings
user_pref("signed.applets.codebase_principal_support", true);

//allow running scripts from srvname without asking
user_pref("capability.principal.codebase.p0.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p0.id", "http://srvname");
user_pref("capability.principal.codebase.p0.subjectName", "");



Actual results:

after restarting the browser my language settings change
my original intl. accept_languages are si en-gb en

after restarting the browser my settings change to en-us en


Expected results:

my language settings shouldn't have changed
(Reporter)

Comment 1

6 years ago
i need to allow some scripts to run local files, because we start some executables from our intranet page. 

we use centos 5.x. with firefox 3.6.x this worked without problems, but now language settings change and since we have a different decimal separator this messes with some of our other intranet pages.
Severity: normal → critical
Component: Untriaged → Preferences
Can you please see if this happens in any previous versions of Firefox 10.0.* ESR?
Severity: critical → normal
(Reporter)

Comment 3

6 years ago
i have observed this behaviour on Firefox 10.0.4 ESR and firefox 10.0.5 ESR
When did it start happening for you? Does it happen in the very first 10.0 ESR release?
(Reporter)

Comment 5

6 years ago
i didn't use any ESR release before 10.0.4.
(In reply to postnalista from comment #5)
> i didn't use any ESR release before 10.0.4.

Can you please test previous versions now?
ftp://ftp.mozilla.org/pub/firefox/releases/
(Reporter)

Comment 7

6 years ago
i tried 10.0.1 and 10.0.0 and the bug is also there.
(Reporter)

Comment 8

6 years ago
anyone?
Can you try back to Firefox 4.0? I'm trying to see if this is a regression. Your testing so far seems to indicate this is not.
(Reporter)

Comment 10

6 years ago
i did some further testing and got the following result.
if i install the mozilla build (Slovenian language) everything seems to work. but if i use the redhat build (which is multilingual) i get the error described above. This is also the reason i could repeat the error before, because i always installed redhat (centos) rpm-s. 
i looked what redhat modifies and all i could find is that they add the folowing settings (from ff 10.0.4):
pref("app.update.enabled", false);
pref("app.update.autoInstallEnabled", false);
pref("browser.display.use_system_colors",   true);
pref("browser.link.open_external",          3);
pref("general.smoothScroll",                true);
pref("general.useragent.vendor", "Red Hat");
pref("general.useragent.vendorSub", "10.0.4-1.el5_8");
pref("intl.locale.matchOS", true);
pref("toolkit.networkmanager.disable", false);
pref("toolkit.storage.synchronous", 0);
pref("browser.startup.homepage", "http://www.redhat.com");
pref("startup.homepage_override_url", "http://www.redhat.com");
pref("startup.homepage_welcome_url", "http://www.redhat.com");
Can you please file a companion bug in Red Hat's bugzilla system? Are you able to reproduce this bug with builds from our ftp.mozilla.org server or only Red Hat's builds? If so, the bug is likely on their end.
(Assignee)

Comment 12

6 years ago
Taking this one.
Assignee: nobody → stransky
(Assignee)

Comment 13

6 years ago
Looks like the intl.accept_languages is not imported from langpack for the second run. It's already fixed in Firefox 13, the latest affected version is Firefox 12.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 14

5 years ago
Already fixed by 17.0.X line.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.