Error: Search service falling back to synchronous initialization in nsSearchService.js

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({regression})

16 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When I start Nightly with a new profile, I get the following error in the Error Console:
"Error: Search service falling back to synchronous initialization at SRCH_SVC__ensureInitialized@resource:///components/nsSearchService.js:2498
@resource:///components/nsSearchService.js:3462
AHU_loadDefaultSearchEngine@resource:///components/nsBrowserContentHandler.js:848
@resource:///components/nsBrowserContentHandler.js:577
dch_handle@resource:///components/nsBrowserContentHandler.js:827

Source File: resource:///components/nsSearchService.js
Line: 2499"

Aurora is unaffected so it's a recent regression.

Comment 1

6 years ago
It's a regression indeed.

Mozregression range:

m-c
good=2012-06-08
bad=2012-06-09
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5891cc95eac7&tochange=95d1bb200f4e

m-i
good=2012-06-07
bad=2012-06-08
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=30fc3d3e10d3&tochange=80e0fe778213

Suspected bug:
David Rajchenbach-Teller — Bug 722332: add an asynchronous initialization API to nsIBrowserSearchService, with a fallback to synchronous initialization for backwards compatibility, r=gavin
(Reporter)

Updated

6 years ago
Keywords: regression
Version: Trunk → 16 Branch
It's not a bug yet :)
It is just a symptom of being between landing of bug 722332 and landing of bug 760035.

This error message marks the fact that we are using a slow path initialization instead of the new fast path initialization. This will be a performance error once bug 760035 lands.
(Reporter)

Updated

6 years ago
Depends on: 760035

Comment 3

6 years ago
Bug 760035 landed, so this time it is bug.
Tomas, normally, this should print a stack. Do you have a copy of that stack, by any chance?
(Reporter)

Comment 5

6 years ago
Is it a dupe of bug 785487?
If it's about the case where you use the profile manager specifically, probably. If it's about the error message in general, no.
AboutHomeUtils was removed in bug 749477 - I filed bug 988017 on fixing it's replacement's use of the search service.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.