SeaMonkey-2.10: regression: new dictionaries not available after installation

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: marcoep, Unassigned)

Tracking

SeaMonkey 2.11 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120611 Firefox/13.0 SeaMonkey/2.10
Build ID: 20120611183817

Steps to reproduce:

Since SeaMonkey-2.10, installed dictionaries are not available any more: neither listed in 'Languages' context menu, nor visible in 'Preferences -> Appearance -> Spelling'. 

I tried with a couple of dictionaries (it_IT and fr-FR) from addons site <https://addons.mozilla.org/en-US/seamonkey/language-tools/>, both in my *current* and in a *fresh* profile.


Actual results:

0. Right click, enable 'Check Spelling'
1. Right click, 'Languages' -> 'Download More Dictionaries...'
2. Install a dictionary
3. Restart
4. Freshly installed dictionary not available


Expected results:

Freshly installed dictionary available (only native English ones are proposed)

Comment 1

6 years ago
Created attachment 633628 [details]
All dictionaries are available

WFM on ru-ru, uk-ua, it_IT and fr-FR dictionaries on
Build identifier: Mozilla/5.0 (Windows NT 5.2; rv:13.0) Gecko/20120604 Firefox/13.0 SeaMonkey/2.10
(Reporter)

Comment 2

6 years ago
The problem persists in SM-2.10.1 (Gentoo Ebuild). It might be a specific [Gentoo] Linux issue... I remember once there was an addons install log, but can't find it any more. BTW, this is the extension log trace:

[download & install]
*** LOG addons.xpi: Download started for https://addons.mozilla.org/seamonkey/downloads/latest/354872/addon-354872-latest.xpi?src=dp-btn-primary to file /tmp/tmp-6f7.xpi
*** LOG addons.xpi: Download of https://addons.mozilla.org/seamonkey/downloads/latest/354872/addon-354872-latest.xpi?src=dp-btn-primary completed.
*** LOG addons.xpi: Starting install of https://addons.mozilla.org/seamonkey/downloads/latest/354872/addon-354872-latest.xpi?src=dp-btn-primary
*** LOG addons.xpi: Addon fr-dicollecte@dictionaries.addons.mozilla.org will be installed as an unpacked directory
*** LOG addons.xpi: Install of https://addons.mozilla.org/seamonkey/downloads/latest/354872/addon-354872-latest.xpi?src=dp-btn-primary completed.

[restart]
*** LOG addons.xpi: startup
*** LOG addons.xpi: checkForChanges
*** LOG addons.xpi: Found updated metadata for fr-dicollecte@dictionaries.addons.mozilla.org in app-profile
*** LOG addons.xpi: Processing install of fr-dicollecte@dictionaries.addons.mozilla.org in app-profile
*** LOG addons.xpi: Opening database
*** LOG addons.xpi: Add-on fr-dicollecte@dictionaries.addons.mozilla.org modified in app-profile
*** LOG addons.xpi: Updating database with changes to installed add-ons
*** LOG addons.xpi: Updating add-on states
*** LOG addons.xpi: Writing add-ons list
(Reporter)

Comment 3

6 years ago
The problem persists with SM-2.11 (Gentoo build). I noticed that even with no dictionary installed via the addons interface, SM proposes anyway EN-based dictionaries; after some investigations, those come from hunspell, which, in Gentoo, always installs myspell-en (indeed, removing it causes SM not to show any dict option). However, any other myspell-* dictionary installed system-wide won't show up in SM, thus it might well be a Gentoo-only issue. I'll file a bug downstream.
Version: SeaMonkey 2.10 Branch → SeaMonkey 2.11 Branch

Comment 4

6 years ago
Ah soo. Gentoo probably builds --with-system-hunspell like many Linux distributions. Perhaps a mismatch with the system hunspell library version and the version SeaMonkey is expecting.
(Reporter)

Comment 5

6 years ago
Let's see what Gentoo folks say; corresponding bug here:

<https://bugs.gentoo.org/show_bug.cgi?id=427228>
(Reporter)

Comment 6

6 years ago
(In reply to Philip Chee from comment #4)
> Ah soo. Gentoo probably builds --with-system-hunspell like many Linux

I guess so, though there's no such flag explicitly set in the Gentoo build. I rather see that a FF's hunspall patch is applied then it's configured with '--enable-system-hunspell        mozilla.org default' which looks like, well... a mozilla default ;-)
Full configure report:

-----------------------------------------------------------------------
# ebuild seamonkey-2.11.ebuild configure
 * seamonkey-2.11.source.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                               [ ok ]
 * firefox-14.0-patches-0.3.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                             [ ok ]
 * seamonkey-2.7-patches-03.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                             [ ok ]
 * enigmail-1.4.3.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                       [ ok ]
 * checking ebuild checksums ;-) ...                                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                                              [ ok ]
>>> Unpacking source...
>>> Unpacking seamonkey-2.11.source.tar.bz2 to /var/tmp/portage/www-client/seamonkey-2.11/work
>>> Unpacking firefox-14.0-patches-0.3.tar.xz to /var/tmp/portage/www-client/seamonkey-2.11/work
>>> Unpacking seamonkey-2.7-patches-03.tar.xz to /var/tmp/portage/www-client/seamonkey-2.11/work
>>> Unpacking enigmail-1.4.3.tar.gz to /var/tmp/portage/www-client/seamonkey-2.11/work
>>> Source unpacked in /var/tmp/portage/www-client/seamonkey-2.11/work
>>> Preparing source in /var/tmp/portage/www-client/seamonkey-2.11/work/comm-release ...
 * Applying various patches (bugfixes/updates) ...
 *   2000-seamonkey_gentoo_install_dirs.patch ...                                                                   [ ok ]
 *   2001_ldap_respect_cflags.patch ...                                                                             [ ok ]
 *   2002_fix-preferences-gentoo.patch ...                                                                          [ ok ]
 *   5000_gconf-config-update.patch ...                                                                             [ ok ]
 * Done with patching
 * Applying various patches (bugfixes/updates) ...
 *   1001-fix_jemalloc_vs_aslr.patch ...                                                                            [ ok ]
 *   2002_fix-preferences-gentoo.patch ...                                                                          [ ok ]
 *   2003_fix_system_hunspell_dict_detection.patch ...                                                              [ ok ]
 *   5000_fix-title-backspace.patch ...                                                                             [ ok ]
 *   5001_allow_locked_prefs_v2.patch ...                                                                           [ ok ]
 *   5002_avoid_spurious_run_items_in_application_handlers.patch ...                                                [ ok ]
 *   5003_properly_launch_applications_set_in_home.patch ...                                                        [ ok ]
 *   5004_use_yarr_instead_of_pcre_on_unsupported_platforms_v2.patch ...                                            [ ok ]
 *   5007_fix_jemalloc_within_libxul.patch ...                                                                      [ ok ]
 *   5009_load_dependent_libraries_with_their_real_path.patch ...                                                   [ ok ]
 *   6001_add_alpha_defines_in_ipc.patch ...                                                                        [ ok ]
 *   6007_dont_hardcode_page_size.patch ...                                                                         [ ok ]
 *   6008_fix_crashreporter_with_gcc_4.7.patch ...                                                                  [ ok ]
 *   6009_fix_system_cairo_support.patch ...                                                                        [ ok ]
 *   7000_freebsd_missing_pthreadnp.patch ...                                                                       [ ok ]
 *   7001_freebsd_intprt_declared.patch ...                                                                         [ ok ]
 *   7002_freebsd_ipc_support.patch ...                                                                             [ ok ]
 *   7003_freebsd_jscpucfg.patch ...                                                                                [ ok ]
 *   7004_freebsd_libexecinfo.patch ...                                                                             [ ok ]
 * Done with patching
 * edos2unix ./db/makefiles.sh
 * Running eautoreconf in '/var/tmp/portage/www-client/seamonkey-2.11/work/comm-release' ...
 * Running autoconf ...                                                                                             [ ok ]
 * Running elibtoolize in: comm-release/mozilla/js/src/ctypes/libffi/
 *   Applying install-sh/1.5.4 patch ...
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 * Running elibtoolize in: comm-release/mozilla/ipc/chromium/src/third_party/libevent/
 *   Applying install-sh/1.5 patch ...
 *   Applying portage/1.5.10 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/1.5.26 patch ...
 * Running elibtoolize in: comm-release/mozilla/tools/profiler/libunwind/src/aux_/
 *   Applying ltmain/1.5 patch ...
 *   Applying portage/1.5.10 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying tmp/1.3.5 patch ...
 *   Applying as-needed/1.5 patch ...
 * Running elibtoolize in: comm-release/mozilla/tools/profiler/libunwind/src/config/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 * Running elibtoolize in: comm-release/mozilla/modules/freetype2/builds/unix/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 * Running elibtoolize in: comm-release/mozilla/toolkit/crashreporter/google-breakpad/autotools/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 * Running autoconf ...                                                                                             [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/www-client/seamonkey-2.11/work/comm-release ...

==========================================================
Building seamonkey-2.11 with the following configuration
    --enable-application=suite      mozilla.org default
    --enable-optimize               mozilla default
    --with-system-jpeg              system_libs
    --with-system-zlib              system_libs
    --enable-pango                  system_libs
    --enable-svg                    system_libs
    --enable-system-cairo           system_libs
    --disable-installer             disable_update_strip
    --disable-pedantic              disable_update_strip
    --disable-updater               disable_update_strip
    --disable-strip                 disable_update_strip
    --disable-strip-libs            disable_update_strip
    --disable-install-strip         disable_update_strip
    --enable-default-toolkit=cairo-gtk2  mozilla.org default
    --enable-ogg                    +alsa
    --enable-wave                   +alsa
    --disable-dbus                  -dbus
    --disable-debug                 -debug
    --disable-tests                 -debug
    --disable-debugger-info-modules  -debug
    --enable-ipc                    +ipc
    --enable-libnotify              +libnotify
    --enable-startup-notification   +startup-notification
    --disable-system-sqlite         -system-sqlite
    --disable-necko-wifi            -wifi
    --enable-webm                   +webm
    --with-system-libvpx            +webm
    --enable-tracejit               mozilla.org default
    --with-system-nspr              mozilla.org default
    --with-nspr-prefix=/usr         mozilla.org default
    --with-system-nss               mozilla.org default
    --with-nss-prefix=/usr          mozilla.org default
    --x-includes=/usr/include       mozilla.org default
    --x-libraries=/usr/lib64        mozilla.org default
    --with-system-libevent=/usr     mozilla.org default
    --enable-system-hunspell        mozilla.org default
    --disable-gnomevfs              mozilla.org default
    --disable-gnomeui               mozilla.org default
    --enable-gio                    mozilla.org default
    --enable-storage                places
    --enable-places                 places
    --enable-places_bookmarks       places
    --enable-oji                    mozilla.org default
    --enable-mathml                 mozilla.org default
    --disable-mochitest             broken
    --prefix=/usr                   mozilla.org default
    --libdir=/usr/lib64             mozilla.org default
    --enable-extensions=default,-irc,-sroaming  mozilla.org default
    --disable-gconf                 mozilla.org default
    --enable-jsd                    mozilla.org default
    --enable-canvas                 mozilla.org default
    --with-default-mozilla-five-home=/usr/lib64/seamonkey  mozilla.org default
    --enable-system-ffi             mozilla.org default
    --with-system-png               mozilla.org default
    --target=x86_64-pc-linux-gnu    mozilla.org default
    --enable-safe-browsing          mozilla.org default
    --disable-system-sqlite         -system-sqlite
    --disable-methodjit             -jit
    --disable-tracejit              -jit
==========================================================

>>> Source configured.
-------------------------------------------------------------------

BTW, looking at how other myspell dictionaries are installed, I see circular symlinks:

lrwxrwxrwx 1 root root       36 Jul 19 16:34 fr-classique.aff -> /usr/share/hunspell/fr-classique.aff
lrwxrwxrwx 1 root root       36 Jul 19 16:34 fr-classique.dic -> /usr/share/hunspell/fr-classique.dic

...the actual dictionary files are installed nowhere!? The bug might well be on hunspell (see this f.i. <https://bugs.gentoo.org/show_bug.cgi?id=356853>)
(Reporter)

Comment 7

6 years ago
Gotcha! I copied some private FF's .dic files into system "/usr/share/myspell" and the new dictionaries popped up in SM's spellcheck/language menu!
So this is definitely a Gentoo/hunspell bug; I'll follow it up downstream. I guess this bug can be marked INVALID.
(Reporter)

Comment 8

6 years ago
BTW, it would be nice to have FF/SM warn users that addon dictionaries cannot be installed alongside system ones, or can they?

Comment 9

6 years ago
Um. sure they can. They are standard myspell/hunspell dictionaries, just packaged as addons.
(Reporter)

Comment 10

6 years ago
I confirm that a bad hunspell/myspell installation was the culprit. Sorry for the noise!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

6 years ago
(In reply to Philip Chee from comment #9)
> Um. sure they can. They are standard myspell/hunspell dictionaries, just
> packaged as addons.

BTW, it looks like this is not possible in SM. After fixing my system-wide hunspell problem I tried to install an addon dictionary: it went through but no new option shows up in the Languages menu. So this might be the real bug...
(In reply to sphakka from comment #11)
> (In reply to Philip Chee from comment #9)
> > Um. sure they can. They are standard myspell/hunspell dictionaries, just
> > packaged as addons.
> 
> BTW, it looks like this is not possible in SM. After fixing my system-wide
> hunspell problem I tried to install an addon dictionary: it went through but
> no new option shows up in the Languages menu. So this might be the real
> bug...

I have both langpacks (i.e. UI languages) and spelling dictionaries installed, and I see both kinds but not together: my langpacks appear under "Languages" and dictionaries (which are all disabled at the moment) appear under "Extensions". I believe that this is intentional.
(Reporter)

Comment 13

6 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #12)
> I have both langpacks (i.e. UI languages) and spelling dictionaries
> installed, and I see both kinds but not together: my langpacks appear under
> "Languages" and dictionaries (which are all disabled at the moment) appear
> under "Extensions". I believe that this is intentional.

Tony, I'm not talking about langpacks; the issue is with system and addon (user) dictionaries. 
In Gentoo, SM is built by default with a system spellchecker support (--enable-system-hunspell); though any user dicts can be installed and do show up in the "addons" list (whereas system-wide ones do not), but do *not* show in the right-click "Language" menu -- they're non functional.
You need to log in before you can comment on or make changes to this bug.