bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Tab Group Missing From "Move to Group" Sub Menu If Empty



Firefox Graveyard
6 years ago
2 years ago


(Reporter: Amr, Unassigned)





6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120615042503

Steps to reproduce:

I always have a tab group named "Readings" which has all the pages that I want to read later in the day. When I open a tab (say from my twitter client), it opens in the currently active tab group (for the work issue I'm working on). Then, I right-click the tab header and move it to the Readings tab group.
If the Readings tab group is empty (has no tabs), it doesn't show up in the "Move to Group" sub menu.

Actual results:

The "Move to Group" sub menu didn't show my custom-named tab group because it's empty (doesn't have any tabs) even though I can see it when I go to panorama view.

Expected results:

The "Move to Group" sub menu should list all the tab groups even if they're empty (especially if they have a custom name).


6 years ago
Component: Untriaged → Panorama
Hardware: x86 → x86_64
If I understood correctly the steps to reproduce would be these:

0. Have two tab groups. (one with a few tabs and the other one empty and with a title name)
1. Open a new tab in the populated group.
2. Right click on the tab and attempt to move it to the empty group.

Expected result: the empty group should be listed and one should have the possibility to move the tab to the empty tab group.

This works for me on Ubuntu with Firefox Nightly (16)

eldib.amr, is there somehting I misunderstood?

Comment 2

6 years ago
That's right Virgil. These are the correct steps to reproduce.
I did try again now to reproduce the problem, and I can't (Nightly 2012-07-09 on Windows 7 x64).
I guess this was fixed in later updates after I submitted this report.
We can close this bug as "Unconfirmed"
Thanks. Closing then.
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 4

6 years ago
The bug is still there in FF Beta 17 on Win7_x64, it just vanishes for the lifetime of the session once panorama view was opened.
So throw in a restart between 1. & 2. to reproduce.

Comment 5

5 years ago
Could anyone be bothered to repro/reopen? It's still happening in Beta 19.
Can reproduce now given that information. This is not a recent regression though (can reproduce with Firefox 4.0 as well).
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Resolution: WORKSFORME → ---
Version: 16 Branch → Trunk
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Last Resolved: 6 years ago2 years ago
Resolution: --- → WONTFIX


2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.