advanced search for questions and sortby replies is broken

RESOLVED FIXED in 2012.11

Status

support.mozilla.org
Search
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

unspecified
2012.11

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=search p=1)

If you do an Advanced Search for Questions and sort by replies, the ES search view code is broken and this kicks up an error. The problem is that the last SORTBY_QUESTION has it sort by '-replies', but that's not an index field. The correct field is 'questions_num_answers'.


Putting this in the 2012.11 sprint and making it a 1 pointer since it's an easy 5 lines fix (create a SORTBY_QUESTIONS_ES with the correct field names and use that in the ES code).
Pushed to production just now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.