crashes if when opening messenger

VERIFIED WORKSFORME

Status

MailNews Core
Profile Migration
P3
major
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Chris Booton, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I tried to open messenger, but it was unable to find prefs.js , so it tried to
migrate it from 4.5 , but failed with a 'unable to determine server type' error
message (in the apprunner text thing that runs in the background) and it crashed
as a result, with;

Date 06/05/1999 Time 12:38
APPRUNNER caused an invalid page fault in
module MSVCRT.DLL at 0177:7800271a.
Registers:
EAX=00000004 CS=0177 EIP=7800271a EFLGS=00010206
EBX=000020d0 SS=017f ESP=0078f120 EBP=0078f140
ECX=00004e43 DS=017f ESI=00000032 FS=5567
EDX=7eff5653 ES=017f EDI=000020d0 GS=0000
Bytes at CS:EIP:
8a 01 41 84 c0 74 3e f7 c1 03 00 00 00 75 f1 05
Stack dump:
038e219d 00004e43 0408e380 0408e390 0408e0c0 0078f160 780012d7 00000010 0078f160
038e2cd7 0408c180 00000004 0408e0c0 038e44dc 0408e57c 0408e550

Comment 1

19 years ago
What were your exact steps?  What do you mean by "migrate from 4.5" since we
don't have a tool/wizard that does that yet.  thanks
(Reporter)

Comment 2

19 years ago
I started by running apprunner, then clicked on the button to open messenger,
and in the apprunner window it says (from when I click on the messenger buton to
the crash):
Created nsToolkitCore
No accounts. I'll try to migrate 4.x prefs..
Tried to upgrade old prefs, but couldn't find server type!

Im not sure what that means, but using norton crash guard I was able to recover
from the crash.

Comment 3

19 years ago
The migration code isn't in there yet.  Have you taken a look at
http://www.mozilla.org/mailnews/prefs-info.html?  You need to manually edit your
preferences to point to your mail directory. You may want to point to your 4.x
mail directory or create a copy (for testing purposes) and point to that copy.

Also, please confirm the build you are using.  When you start up apprunner, in
the browser window, look at the lower left corner of the window for the build
ID.

However, even though we don't migrate the prefs, we shouldn't be crashing.
(Reporter)

Comment 4

19 years ago
I'm using build 1999052619

Comment 5

19 years ago
Ok, you are using the M6 build (latest release).  Let me know your results from
the preferences file comment I made.  At least, I'd like to have you set up to
use Messenger :-)
(Reporter)

Comment 6

19 years ago
I open it and the apprunner text says:
Created nsToolkitCore
Loading preferences for account: account1
Loading preferences for account: account2
Loading preferences for account: account3

but then it crashed with:

APPRUNNER caused an invalid page fault in
module MSVCRT.DLL at 0177:7800271a.
Registers:
EAX=00000004 CS=0177 EIP=7800271a EFLGS=00010206
EBX=000020d0 SS=017f ESP=0078f120 EBP=0078f140
ECX=00004e43 DS=017f ESI=00000032 FS=21e7
EDX=7eff5653 ES=017f EDI=000020d0 GS=0000
Bytes at CS:EIP:
8a 01 41 84 c0 74 3e f7 c1 03 00 00 00 75 f1 05
Stack dump:
038e219d 00004e43 03ec2340 03ec2350 03ec2060 0078f160 780012d7 00000010 0078f160
038e2cd7 03ec2080 00000004 03ec2060 038e44dc 03ec253c 03ec2510

Updated

19 years ago
Assignee: dbragg → lchiang

Comment 7

19 years ago
Do you get a Talkback report?  This helps us to see specific line numbers where
the crash is.

Comment 8

19 years ago
I'll assign to me until we narrow down further the cause of the problem.

Comment 9

19 years ago
Lisa,
I am reproducing this on Linux today.  When I click on icon to open messenger,
my unix window shows the following.
Created nsToolkitCore
No accounts. I'll try to migrate 4.x prefs..
nsMessenger::SetWindow():Getting the webShell of interest...
nsMessenger::SetWindow():Getting the webShell of interest...

I do not crash, I hang.
Do you want me to open separate bug for Linux or include here?

Comment 10

19 years ago
Grace, for Linux, do you have a prefs50.js file already there?

csbooton@myna.com, do you have a prefs50.js already created?

Comment 11

19 years ago
Yes, prefs50.js was just created prior to launching apprunner.

Comment 12

19 years ago
Grace - go ahead and file a separate bug until we narrow down more with the bug
reporter on this Win32 bug.
(Reporter)

Comment 13

19 years ago
Yes, I did create a prefs50.js and it got as far as displaying the names of
accounts but crashed before I could do anything, it did get a talkback, but the
and was not able to send it until today. Strangly enough today when I do it, it
works without crashing, but no accounts are diaplyed, but this is likley the
result of an error in my prefs50.js file.

Comment 14

19 years ago
csbooton@myna.com - since you no longer are experiencing a crash (and you don't
have a talkback ID we can track), can I mark this bug as worksforme?  Offline
(via email exchange), I can work with you to get your prefs file so you are able
to see your mail.  How does this sound?
(Reporter)

Comment 15

19 years ago
it sounds good, but unfortunatly it has started to crash again. I checked my
prefs50.js and it appears to be fine, this time when it crashes, the apprunner
window says 'loading profile *' for each profile, then it crashes. I was able to
get a talkback for it, it is incident #TB9719421G

Comment 16

19 years ago
The tracking ID doesn't do much good.  Do you have an incident ID (which
consists of all numbers)?  I went to http://cyclone to do a "fast find" on your
email address and didn't see any recent incidents after 5/30.

You are running a release build and not any debug builds, right?

And, you don't get a crash with just the browser?  Only with Messenger, right?
(Reporter)

Comment 17

19 years ago
I'm using M6, and yes it only happenes with messenger, I dont know why it
doesent have my e-mail address I entered it in the enter e-mail address text
box.
(Reporter)

Comment 18

19 years ago
Acording to talkback #TB9719421G is the incident id as this is what it is listed
as under the crashes list. I've just made it crash again, this time it showed my
e-mail account and new.mozilla.org, but it froze for a second and crashed. It
lists the incident (I can find no evidence of a tracking ID listed anywhere) id
as #TB9772574G .
(Reporter)

Comment 19

19 years ago
I'm now using the 1999061409 build and it still crashes. before starting this
time I ran apprunner with the -installer command line, and it asked me to
migrate a profile and I did and it appeard to work, but once again when i click
on the messenger icon and it loads messenger. I got a dR. watson file on it and
it says:

Microsoft (R) C Runtime Library attempted to use a null data pointer variable.

Module Name: MSVCRT.DLL
Description: Microsoft (R) C Runtime Library
Version: 5.00.7022
Product: Microsoft (R) Visual C++
Manufacturer: Microsoft Corporation

Application Name: Apprunner.exe

I'll atach the actual report file so you can view the entire thing.
(Reporter)

Comment 20

19 years ago
Created attachment 428 [details]
My Dr watson report file for the infamous messenger crash
(Reporter)

Updated

19 years ago
Summary: crashes if it has problems migrating profiles → crashes if when opening messenger
(Reporter)

Comment 21

19 years ago
(Changed the name of the summnary to make it more clear as to what the problem
is)

Updated

19 years ago
Assignee: lchiang → phil

Comment 22

19 years ago
Phil, do you know who may be able to help with this?  Opening messenger for this
bug reporter results in a crash.  I am out of ideas.

Updated

19 years ago
Assignee: phil → alecf

Comment 23

19 years ago
Sounds like multiple account stuff, so reassigning to alecf to try it out.
Unfortunately, the talkback report doesn't have a stack trace (sent mail to
leger separately about that), so we'll probably need the prefs file to
investigate.

Comment 24

19 years ago
csbooton@myna.com - can you attach the prefs50.js file that you're using when
this crash occurs?  Please strip out your mail password from this file before
attaching.  thanks.
(Reporter)

Comment 25

19 years ago
Created attachment 433 [details]
When i started with the -installer on the command line this is what the prefs50.js file ends up looking like.
(Reporter)

Comment 26

19 years ago
Well, I downloaded build 1999061509, and before installing it deleted the mozilla regestry, plus my mozilla directory and my users50 directory and the crash has gone away, at least for now. Perhaps it had something to do with a file conflict from installing new versions over old version? With this I think you can change the resolution to worksforme

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
Target Milestone: M7

Comment 27

19 years ago
Marking Verified/WorksForMe per reporters request.

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.