Define make rule to install mochitests

RESOLVED DUPLICATE of bug 370750

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 370750
6 years ago
2 months ago

People

(Reporter: gps, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
AFAICT there is no defined rule in the build system to install mochitests. Instead, there is a common pattern:

>_TEST_FILES = foo bar $(NULL)
>
>libs:: $(_TEST_FILES)
>    $(INSTALL) $(foreach f,$^,"$f") $(DEPTH)/_tests/testing/mochitest/tests/$(relativesrcdir)

For chrome mochitests, we do the same thing except with a different variable for the file list and we install to $(DEPTH)/_tests/testing/mochitest/chrome/$(relativesrcdir). Ditto for browser mochitests.

We like having specially named variables cause side-effects from inherited rules, so let's implement something for mochitests.

This bug only tracks defining the rule and possibly converting one or two Makefiles in the tree. Converting all the Makefiles will take a long time, as there are many instances of this pattern over the tree e.g. https://mxr.mozilla.org/mozilla-central/search?string=TEST_FILES&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central. The good news is converting things is largely a manual process and could be a good mentored bug.

I believe that once this is done, it will substantially reduce the number of overall rules in Makefiles. And, if we do it right, it may allow us to uplift MOCHITEST_FILES, etc lists into parent Makefiles, eliminating a handful of Makefiles from the tree.
We have an ancient bug on this. Still want it fixed, though!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370750

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.