Self-serve should allow me to perform cancel/rebuild on multiple builds

RESOLVED DUPLICATE of bug 625168

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 625168
6 years ago
a year ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Unassigned)

Tracking

({buildapi, sheriffing-P3})

Firefox Tracking Flags

(Not tracked)

Details

Clicking a button causes a new page to load. When I want to rebuild several builds (or cancel several) I have to 1) click button, 2) wait for load, 3) go back. This is further complicated by the fact that the UI resets each time (if I was viewing build #33, for instance, I would have to re-expand the view and then scroll to see the next build).

Can we get rid of the buttons entirely? If there were links then at least I could right click and do an 'open in new tab' perhaps.

But ideally I think we should have a checkbox next to each build and then a 'Rebuild selected' or 'Cancel selected' button at the bottom.
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: release → catlee
Component: Release Engineering: Automation (General) → Release Engineering: Developer Tools
QA Contact: catlee → lsblakk
QA Contact: lsblakk → hwine

Updated

6 years ago
Duplicate of this bug: 784348

Updated

6 years ago
Whiteboard: [buildapi][selfserve][sheriff-want]
(In reply to ben turner [:bent] from comment #0) 
> But ideally I think we should have a checkbox next to each build and then a
> 'Rebuild selected' or 'Cancel selected' button at the bottom.

That alone would make it very impractical for triggering multiple rebuilds of the same build/test-suite (e.g. for checking for intermittent failures).

Updated

6 years ago
Keywords: buildapi

Updated

6 years ago
Keywords: sheriffing-P3
Whiteboard: [buildapi][selfserve][sheriff-want]
FWIW i built a quick'n'dirty userscript: 
http://userscripts.org/scripts/show/157514
I wanted it for triggering N rebuilds of the same build, but i guess it fulfills the requirements here as well.
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625168
(Assignee)

Updated

a year ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.