Basic sidebar search is non-functional

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Search
P1
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Claudius Gayle, Assigned: matt)

Tracking

({intl, regression})

Trunk
mozilla0.9.1
intl, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 2 days)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
***Overview Description: 
  It is not currently possible to do searches in the MySidebar Search tab.

***Steps to Reproduce: 
1) Open your sidebar to the Search tab
2) type a search term and click 'Search'


***Actual Results: 
	The browser looks busy for a sec and the button changes to 'Stop'
Then it reverts to 'Search' and nothing has happened. No results in the Sidebar
(this may be a result of another related bug) AND no results in the content window.

***Expected Results: 

Search results in the sidebar and the content window.

***Build Date & Platform Info: 

This bug was originally found by lynnw@netscape.com on the 2001041604 WinNT build.
I however don't seem to be able to reproduce it on a 2001041704 Win98 build
but it does repro on MacOS and Linux builds of the same timestamp.
(Reporter)

Comment 1

17 years ago
I forgot to keyword this. This bug is pretty serious.
Keywords: nsbeta1, regression
(Assignee)

Comment 2

17 years ago
I'm still not seeing this on my machine....rebuilding and will try again

Comment 3

17 years ago
More info can be found at http://bugscape.netscape.com/show_bug.cgi?id=4671
which was where this bug originally was filed before we moved it to Bugzilla
(open source)

Comment 4

17 years ago
Using US Windows 98, Recommended install, 042404 build, bug reproduces as 
described above.

However, I just saw Sidebar Search work on TPringle's machine with the same 
build, but I do not know which type of install he used.

Nominating nsbeta1+
Keywords: intl
nsbeta1+. 
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.1

Comment 6

17 years ago
After a recommended and full install of build 2001042420, I see that the 
default basic sidebar search is still broken.
(Reporter)

Comment 7

17 years ago
matt, maybe try an opt build or <gulp> commercial build? I can still repro this on three
different platforms with a mix of new/old profiles on the 20010426 builds. Lynnw and others
have seen this as well. Although, there is one reprot of someone else w/a build that should've
showed the bug but did not.
(Assignee)

Comment 8

17 years ago
the build I showed you it working was commercial optimized.
I've tried 2 machines....3 types of builds.
We need to sit down together and look at this.  What a pain in the ars this bug 
is.

Updated

17 years ago
Whiteboard: 2 days

Comment 9

17 years ago
Basic sidebar search works if the user switches to Advanced, performs a search 
and then switches back to Basic. Suggests that default search is not working. 
This test was performed in build 20010508 (commercial).
(Assignee)

Comment 10

17 years ago
Created attachment 33907 [details] [diff] [review]
patch file for sidebar panel
(Assignee)

Comment 11

17 years ago
need reviews

Comment 12

17 years ago
this is the same patch as is in bug 73238
(Assignee)

Comment 13

17 years ago
fixed
To test try searching multi times.
with new profile.
Do advanced also.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

17 years ago
all better now. VERIFIED Fixed with 20010511 builds
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.