No recipients dlg appears while sending mail with recipient

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P2
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Sheela Ravindran, Assigned: Jean-Francois Ducarroz)

Tracking

({regression})

Trunk
mozilla0.9.1
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

17 years ago
buildid:2001-04-18-08 and 2001-04-17-06

Having specified the recipient the first time trying to send the message 
complains about not specifying a recipient.  This only happens when launching 
the application from the command prompt with -mail.  If you open mail from the 
browser task menu bar you will not see this problem.  This happens only with the 
first compose window and the first time you want to send mail.  When you close 
that widow cancelling sending or saving it to drafts. The next new message can 
be composed and send successfully without even restarting the application.  

steps to reproduce:
start the application with -mail from the command prompt
click new message 
compose a test message
Make sure you specify a recipient
Try to send this message 
Actual Result:  No recipient were specified.  Please enter a recipient or 
newsgroup in the addressing area
(Reporter)

Comment 1

17 years ago
change qa contact to myself. nominating for nsbeta1 so that bug can be fixed.
JFD, 
let me know if you are not able to reproduce this bug.
Keywords: nsbeta1, regression
QA Contact: esther → sheelar

Comment 2

17 years ago
I am unable to reproduce this using this morning's release build as well as my
debug build today.
(Assignee)

Comment 3

17 years ago
this is the problem seth reported a while ago that we are not able to reproduce 
all the time...

*** This bug has been marked as a duplicate of 73048 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
Well this bug did not have anything to do with the send format dlg (intelligent
send) that comes up while sending html text.  I was typing just plain text in
the html compose and it happens only the firt time you launch mail, compose and
try to send. I was able to reproduce this on Stephen's linux machine too on
today's build.  However, the error reported by seth did have the same no
recipients dlg appearing. I am still seeing this on my linux - buildid
2001041708.  As a matter of fact it is very annoying that I cannot send mail the
first time I compose after launching the application.  
This was on my machine when Sheela showed this to me, I don't think it a DUP of
that HTML message, we were sending plain text, and were able to send *only* the
2nd time after an unsuccessful send (no recipients specified alert() ).  Linux
build 2001041808.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

17 years ago
When do you have the problem, are you able to enter more than one recipients (on
separated rows)?
(Reporter)

Comment 7

17 years ago
JFD,
The first time you open mail and open compose window by clicking new message 
button. You cannot enter more than one recipient.  That is when with one 
recipient when you try sending mail is when you would see this error. But if you 
close this window and open a new compose window no problem.  You can enter 
multiple recipients and also send mail in the same session.
(Assignee)

Comment 8

17 years ago
this is the same problem than bug 73048 but until now we weren't able to figure
out how the reproduce the problem at 100%. For some obscure reason, I cannot
read the date of the input field!!!

Updated

17 years ago
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 9

17 years ago
Sheelar, do you still see this problem?
Status: REOPENED → ASSIGNED

Comment 10

17 years ago
I'm seeing this problem on 2001050209, for what that's worth. Been seeing it for
a while.
I've kind of gotten the impression that if I type the text of my message and
then type the recipient's address, I don't get the problem. It's if the first
thing I do is enter a recipient that I get the problem (the cursor automatically
goes to the recipient field).
I've also seen the problem several times since I ran mail/news, not just the
first message after running the app (I've seen it with new mesgs and fwds).
(Assignee)

Comment 11

17 years ago
I think this problem is gone since the landing of the new modern theme and the
new autocomplete widget. Please try it again with a recent build. Thanks
(Reporter)

Comment 12

17 years ago
buildid:2001050706 on linux, 
JFD,
I don't see the no recipients dialog anymore. This is not a problem anymore. I
guess this can be a worksforme.  I have been using this build for 2 days now and
have not come across the problem.  You can mark it fixed or worksforme and I
will verify it. 
(Assignee)

Comment 13

17 years ago
good. WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 14

17 years ago
*** Bug 80253 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
VERIFIED
Status: RESOLVED → VERIFIED

Comment 16

17 years ago
I have the problem with  Build 2001050521. can anybody say if its fixed in later versions ? I still have the problem. I can't enter more than one recp. and it refuses to send. My workaround is to hit the "adress" button, add a known recp. and the deleting it again in the field (not address dialog).
(Reporter)

Comment 17

17 years ago
*** Bug 94665 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

17 years ago
Reopening this bug based on comments from bug 94665. This problem has been by a 
few people in the latest builds. However, this happens the first time composing 
mail that the recipient is not recognised.  
Please see bug 94665 that this problem seems to have come back since many people 
have reported seeing this already. 
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 19

17 years ago
I close this bug as before and leave the new bug open since the new problem
could be related to a different issue all together. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 20

17 years ago
This sounds exactly like the bug I'm still experiencing in Moz 0.9.5.  I opened
bug 94665.  I always open Moz with -mail and pretty much always the first
message I compose (if new and not a reply) doesn't recognize the To field.  The
drop down address selection box doesn't pop up etc.

So I would say that this bug is most certainly NOT "RESOLVED WORKSFORME".


 
(Reporter)

Comment 21

17 years ago
verified 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.