NavigationTiming data wrong for tabs loaded on demand (browser.sessionstore.restore_on_demand)

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: cobexer, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 2012060100

Steps to reproduce:

I have a Firefox session with multiple tabs open, and i use on demand tab loading (browser.sessionstore.restore_on_demand).
after using Firefox for about 20 minutes i switched to my open Twitter tab(which was not yet loaded) and noticed that the Addon https://addons.mozilla.org/en-US/firefox/addon/apptelemetry/ displayed strange values, i opened the developer console and checked window.performance.timing and noticed that navigationStart was about 20 minutes in the past.


Actual results:

window.performance.timing.navigationStart represented the browser start time instead of the time i clicked the twitter tab; additionally window.performance.navigation.type was set to 2


Expected results:

window.performance.timing.navigationStart should have represented the time I clicked on the twitter tab for the first time. window.performance.navigation.type should be set to 0
(Reporter)

Comment 1

6 years ago
I just loaded the twitter tab again(that is in the Firefox i started today i clicked it using on demand loading):
connectEnd	1338061385846
connectStart	1338061385846
domComplete	1338061385846
domContentLoadedEventEnd	1338061385846
domContentLoadedEventStart	1338061385846
domInteractive	1338061385846
domLoading	1338061385846
domainLookupEnd	1338061385846
domainLookupStart	1338061385846
fetchStart	1338061385846
loadEventEnd	1338061385846
loadEventStart	1338061385846
navigationStart	1340208869494
redirectEnd	0
redirectStart	0
requestStart    1338061385846
responseEnd	1338061385846
responseStart	1338061385846
unloadEventEnd	1338061385846
unloadEventStart	1338061385846

notice how navigationStart is the only one with a valid value...
>>> new Date(window.performance.timing.navigationStart)
Date {Wed Jun 20 2012 18:14:29 GMT+0200 (CEST)}
>>> new Date(window.performance.timing.fetchStart)
Date {Sat May 26 2012 21:43:05 GMT+0200 (CEST)}
>>> new Date(window.performance.timing.loadEventStart)
Date {Sat May 26 2012 21:43:05 GMT+0200 (CEST)}
Do you get the same results under the latest Nightly?
ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
Component: Untriaged → General
QA Contact: untriaged → general
Whiteboard: [telemetry]
(Reporter)

Comment 3

6 years ago
Firefox nightly shows good values, it seems to be caused by some addon - that will take me some time to figure out, I'll report back which one was causing this...

also interesting is that my addons are actually synced across multiple computers and the problem is not reproducible across all of them...
(Reporter)

Comment 4

6 years ago
it seems to be caused by the addon "SmartVideo For YouTube 0.97", i was able to reproduce this issue with a new, empty profile using Firefox 13.0.1 x86_64 on openSuSE 12.2 (Factory).
(In reply to cobexer from comment #4)
> it seems to be caused by the addon "SmartVideo For YouTube 0.97", i was able
> to reproduce this issue with a new, empty profile using Firefox 13.0.1
> x86_64 on openSuSE 12.2 (Factory).

Can you please clarify this statement. If you can reproduce this in a new empty profile without SmartVideo installed then that means this bug can't be caused by that add-on.
(Reporter)

Comment 6

6 years ago
I was able to reproduce this issue with a new, fresh profile using Firefox 13.0.1 with the "SmartVideo For YouTube 0.97" addon (and app.telemetry Page Speed Monitor 12.3.2) but no other addons and no settings i might have in my ages old profile

sorry for the confusion
Okay, thank you. I suspect this is not a Firefox bug in this case. Can you please report this issue to the add-on developer? Looks like this might be the page:
https://addons.mozilla.org/en-US/firefox/addon/smartvideo-for-youtube-mytube/

If you find evidence that this is a Firefox bug and not something to do with the add-on, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Whiteboard: [telemetry]
You need to log in before you can comment on or make changes to this bug.