Last Comment Bug 765524 - Register PrefChanged for CUBEB_LATENCY_MS so the pref has an effect
: Register PrefChanged for CUBEB_LATENCY_MS so the pref has an effect
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Matthew Gregan [:kinetik]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-16 17:41 PDT by Matthew Gregan [:kinetik]
Modified: 2012-06-19 01:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v0 (1.14 KB, patch)
2012-06-16 17:42 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Splinter Review
patch v1 (3.70 KB, patch)
2012-06-16 19:14 PDT, Matthew Gregan [:kinetik]
cpearce: review+
Details | Diff | Splinter Review

Description Matthew Gregan [:kinetik] 2012-06-16 17:41:38 PDT

    
Comment 1 Matthew Gregan [:kinetik] 2012-06-16 17:42:49 PDT
Created attachment 633851 [details] [diff] [review]
patch v0
Comment 2 Matthew Gregan [:kinetik] 2012-06-16 19:14:43 PDT
Created attachment 633862 [details] [diff] [review]
patch v1

Same intent as previous patch, but need to pass a default to GetUint, otherwise it returns 0 and we end up forcing the minimum latency (20ms) when the pref is unset.  This version removes the default initializers for all of the prefs, since they should never be used before they're initialized and it's confusing to have a default value here and where the pref is fetched.

Also removes references to unused mozilla::TimeStamp.
Comment 3 Matthew Gregan [:kinetik] 2012-06-18 20:24:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e22422f1cc59
Comment 4 Ed Morley [:emorley] 2012-06-19 01:18:09 PDT
https://hg.mozilla.org/mozilla-central/rev/e22422f1cc59

Note You need to log in before you can comment on or make changes to this bug.