Using address picker leads to a crash

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: marina, Assigned: chuang)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
**** observed with 2001-04-18 build ****
Steps to repro:
- open new mail composition;
-click on Address icon;
-select a recipient;
- OK dlgbox;
//note: seamonkey crashes
(Reporter)

Comment 1

17 years ago
here is a stack:

 Call Stack:    (Signature = nsHTMLInputElement::SetFocus abc9dd36) 
     
   nsHTMLInputElement::SetFocus 
                                                
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp, 
line 689]
     
   nsEventStateManager::PreHandleEvent 
                                                
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 
487]
     
   PresShell::HandleEventInternal 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5402]
     
   PresShell::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5334]
     
   nsView::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 377]
     
   nsViewManager::DispatchEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2039]
     
   HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     
   nsWindow::DispatchEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 708]
     
   nsWindow::DispatchWindowEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 725]
     
   nsWindow::DispatchFocus 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4213]
     
   nsWindow::ProcessMessage 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3146]
     
   nsWindow::WindowProc 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 960]
     
   USER32.dll + 0x1303 (0x77e71303) 
                                                 
     
   USER32.dll + 0x1962 (0x77e71962) 
                                                 
     
   ntdll.dll + 0x163ef (0x77f763ef) 
                                                 
     
   GlobalWindowImpl::Focus 
                                                
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 1658]
     
   nsWebShellWindow::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 527]
     
   nsWindow::DispatchEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 708]
     
   nsWindow::DispatchWindowEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 725]
     
   nsWindow::DispatchFocus 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4213]
     
   nsWindow::ProcessMessage 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3142]
     
   nsWindow::WindowProc 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 960]
     
   USER32.dll + 0x1303 (0x77e71303) 
                                                 
     
   USER32.dll + 0x1962 (0x77e71962) 
                                                 
     
   ntdll.dll + 0x163ef (0x77f763ef) 
                                                 
     
   USER32.dll + 0x1350 (0x77e71350) 
                                                 
     
   nsWindow::DefaultWindowProc 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 986]
     
   USER32.dll + 0x2c6a (0x77e72c6a) 
                                                 
     
   USER32.dll + 0x2cf5 (0x77e72cf5) 
                                                 
     
   nsWindow::WindowProc 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 971]
     
   USER32.dll + 0x1303 (0x77e71303) 
                                                 
     
   USER32.dll + 0x1962 (0x77e71962) 
                                                 
     
   ntdll.dll + 0x163ef (0x77f763ef) 
                                                 
     
   nsWebShellWindow::Destroy 
                                                
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 1735]
     
   nsChromeTreeOwner::Destroy 
                                                
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsChromeTreeOwner.cpp, line 227]
     
   GlobalWindowImpl::Close 
                                                
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2114]
     
   GlobalWindowImpl::CloseWindow 
                                                
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3034]
     
   nsJSContext::ScriptEvaluated 
                                                
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1334]
     
   nsJSContext::CallEventHandler 
                                                
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 948]
     
   nsJSEventListener::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
     
   nsEventListenerManager::HandleEventSubType 
                                                
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1034]
     
   nsEventListenerManager::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1956]
     
   nsXULElement::HandleDOMEvent 
                                                
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3673]
     
   PresShell::HandleDOMEventWithTarget 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5455]
     
   nsButtonBoxFrame::MouseClicked 
                                                
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 181]
     
   nsButtonBoxFrame::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 128]
     
   PresShell::HandleEventInternal 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5424]
     
   PresShell::HandleEventWithTarget 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5379]
     
   nsEventStateManager::CheckForAndDispatchClick
                                                
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 
2293]
     
   nsEventStateManager::PostHandleEvent 
                                                
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 
1393]
     
   PresShell::HandleEventInternal 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5428]
     
   PresShell::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5334]
     
   nsView::HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 377]
     
   nsViewManager::DispatchEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2039]
     
   HandleEvent 
                                                
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     
   nsWindow::DispatchEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 708]
     
   nsWindow::DispatchWindowEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 725]
     
   nsWindow::DispatchMouseEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4030]
     
   ChildWindow::DispatchMouseEvent 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4273]
     
   nsWindow::ProcessMessage 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3038]
     
   nsWindow::WindowProc 
                                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 960]
     
   USER32.dll + 0x124c (0x77e7124c) 
                                                 

Comment 2

17 years ago
I see that happens on all platforms using these builds.
Linux (2001-04-18-05 trunk)
Win32 (2001-04-18-06 trunk)
Mac (2001-04-18-11 trunk)

Updated

17 years ago
QA Contact: esther → fenella

Comment 3

17 years ago
Stack trace looks identical to the latest one submitted for bug 76125.  Marking 
dup.

*** This bug has been marked as a duplicate of 76125 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
fenella, is it really a dup of 76125? the fact that they call the same dll make 
them dup? the description of the dup reffers to komodo build and suggest the use 
of 4 hours (?)then hang and then crash. is it the same problem? reopening till 
we decide that they actually are dups
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
dup of bug 76715.

Comment 6

17 years ago
This looks like it could be a dup of 76780

Comment 7

17 years ago
Linux (2001-04-23-05 trunk)
Win32 (2001-04-23-06 trunk)
Mac (2001-04-23-08 trunk)
This bug is gone. Mark it worksforme.

Marina, if you see it happen again, please feel free to re-open it.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.