Telemetry Dashboard should explain why it needs to track users

RESOLVED WONTFIX

Status

Mozilla Metrics
Frontend Reports
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: Jesper Kristensen, Unassigned)

Tracking

unspecified
Unreviewed

Details

(Reporter)

Description

6 years ago
The Telemetry Dashboard at https://metrics.mozilla.com/ requires you to log in. But there is no explanation why that is required. I have been told that everybody can create an account and see everything, so I don't see the point of requiring login. The only purpose for the login requirements seems to be to get the user's private data (email address). I am sure that there is a good explanation for this. Mozilla is after all not an organization known for collecting private data just for the fun of it. But I have not been able to find that explanation anywhere, and I think it should be stated somewhere on the site itself.

Comment 1

6 years ago
I can answer this one


Simply put, we don't have the infrastructure to put it totally open, so that is a way to prevent a otherwise much bigger fow of requests. 

 
So instead of waiting for the hardware to be available, we prefered to allow users to consume the data in this less than ideal situation. Just that :)


I'll leave it to the telemetry team the decision to add that disclamer, but personally feel it's a very relevant question

Pedro (metrics team)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.