Kuma: /fr/docs/en-US/CommonJS/Process$history - DoesNotExist: User matching query does not exist.

RESOLVED DUPLICATE of bug 765606

Status

Mozilla Developer Network
Editing
RESOLVED DUPLICATE of bug 765606
6 years ago
5 years ago

People

(Reporter: lorchard, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
No idea what's going on here.



Traceback (most recent call last):

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django-waffle/waffle/decorators.py", line 20, in _wrapped_view
    return view(request, *args, **kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django/django/views/decorators/http.py", line 37, in inner
    return func(request, *args, **kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/apps/wiki/views.py", line 133, in process
    return func(request, *args, **kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/apps/wiki/views.py", line 982, in document_revisions
    {'revisions': revs_out, 'document': doc})

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 78, in render
    rendered = render_to_string(request, template, context)

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
    return template.render(**get_context())

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/django/developer.mozilla.org/kuma/apps/wiki/templates/wiki/document_revisions.html", line 6, in top-level template code
    {% set crumbs = [(url('wiki.category', document.category), document.get_category_display()),

  File "/data/www/django/developer.mozilla.org/kuma/apps/wiki/templates/wiki/base.html", line 7, in top-level template code
    {% set scripts = ('wiki',) %}

  File "/data/www/django/developer.mozilla.org/kuma/templates/base.html", line 153, in top-level template code
    {% block content %}{% endblock %}

  File "/data/www/django/developer.mozilla.org/kuma/apps/wiki/templates/wiki/document_revisions.html", line 78, in block "content"
    {{ rev.creator }}

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 371, in getattr
    return getattr(obj, attribute)

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django/django/db/models/fields/related.py", line 313, in __get__
    rel_obj = QuerySet(self.field.rel.to).using(db).get(**params)

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django/django/db/models/query.py", line 347, in get
    % self.model._meta.object_name)

DoesNotExist: User matching query does not exist.


<WSGIRequest
GET:<QueryDict: {}>,
POST:<QueryDict: {}>,
COOKIES:{},
META:{'CSRF_COOKIE': '390d9405c88a78586d375181e572748c',
 'DOCUMENT_ROOT': '/data/www/dekiwiki',
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTPS': 'on',
 'HTTP_ACCEPT': '*/*',
 'HTTP_ACCEPT_ENCODING': 'gzip,deflate',
 'HTTP_CONNECTION': 'Keep-alive',
 'HTTP_FROM': 'googlebot(at)googlebot.com',
 'HTTP_HOST': 'developer.mozilla.org',
 'HTTP_SSLCLIENTCERTSTATUS': 'NoClientCert',
 'HTTP_SSLCLIENTCIPHER': 'SSL_RSA_WITH_RC4_128_SHA, version=TLSv1, bits=128',
 'HTTP_SSLSESSIONID': 'F493C22552C5AE90D12B65CDF46D35AA8D1F25205F880739C9D27C17CFDAECBC',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)',
 'HTTP_X_CLUSTER_CLIENT_IP': '66.249.68.17',
 'PATH_INFO': u'/fr/docs/en-US/CommonJS/Process$history',
 'PATH_TRANSLATED': 'redirect:/mwsgi/fr/docs/en-US/CommonJS/Process$history/docs/en-US/CommonJS/Process$history',
 'QUERY_STRING': '',
 'REDIRECT_HTTPS': 'on',
 'REDIRECT_SCRIPT_URI': 'http://developer.mozilla.org/fr/docs/en-US/CommonJS/Process$history',
 'REDIRECT_SCRIPT_URL': '/fr/docs/en-US/CommonJS/Process$history',
 'REDIRECT_STATUS': '200',
 'REDIRECT_URL': '/fr/docs/en-US/CommonJS/Process$history',
 'REDIRECT_force-proxy-request-1.0': '1',
 'REDIRECT_proxy-nokeepalive': '1',
 'REMOTE_ADDR': '10.22.81.210',
 'REMOTE_PORT': '60101',
 'REQUEST_METHOD': 'GET',
 'REQUEST_URI': '/fr/docs/en-US/CommonJS/Process$history',
 'SCRIPT_FILENAME': '/data/www/django/developer.mozilla.org/kuma/wsgi/kuma.wsgi',
 'SCRIPT_NAME': u'',
 'SCRIPT_URI': 'http://developer.mozilla.org/fr/docs/en-US/CommonJS/Process$history',
 'SCRIPT_URL': '/fr/docs/en-US/CommonJS/Process$history',
 'SERVER_ADDR': '10.22.81.30',
 'SERVER_ADMIN': 'webmaster@mozilla.com',
 'SERVER_NAME': 'developer.mozilla.org',
 'SERVER_PORT': '80',
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SIGNATURE': '',
 'SERVER_SOFTWARE': 'Apache',
 'force-proxy-request-1.0': '1',
 'mod_wsgi.application_group': 'developer.mozilla.org|/mwsgi',
 'mod_wsgi.callable_object': 'application',
 'mod_wsgi.handler_script': '',
 'mod_wsgi.input_chunked': '0',
 'mod_wsgi.listener_host': '',
 'mod_wsgi.listener_port': '81',
 'mod_wsgi.process_group': 'mdn_prod',
 'mod_wsgi.request_handler': 'wsgi-script',
 'mod_wsgi.script_reloading': '1',
 'mod_wsgi.version': (3, 3),
 'platform.name': 'dekiwiki3.webapp.scl3.mozilla.com',
 'proxy-nokeepalive': '1',
 'wsgi.errors': <mod_wsgi.Log object at 0xa6f5a98>,
 'wsgi.file_wrapper': <built-in method file_wrapper of mod_wsgi.Adapter object at 0xa6e8848>,
 'wsgi.input': <mod_wsgi.Input object at 0xa6f5930>,
 'wsgi.loaded': datetime.datetime(2012, 6, 17, 11, 46, 2, 928410),
 'wsgi.multiprocess': True,
 'wsgi.multithread': False,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'https',
 'wsgi.version': (1, 1)}>
(Reporter)

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
This seems fixed by removing the kumawiki waffle flag on developer.mozilla.org altogether. So I'm going to call this a dup of bug 765606
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765606
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.