all kvm hosts that are part of releng infra should be in inventory

RESOLVED INVALID

Status

Infrastructure & Operations
RelOps
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: bear, Assigned: arr)

Tracking

Details

(Whiteboard: [buildduty][outage])

(Reporter)

Description

6 years ago
As part of the MV network downtime recovery we discovered that some of the slaves were not getting name resolves for mv-production-puppet so that lead #infra on a search for that name server.

After realizing that it is ns1.build.mtv1.mozilla.com we found that it is not part of inventory.

[00:37]  <fox2mike> bear: can you file a bug to relops to get all these kvms in inventory
[00:37]  <fox2mike> ?
[00:37]  <fox2mike> or I could I guess
[00:37]  <bear> I'll do it
[00:37]  <bear> your helping, I can pick up the side stuff
[00:38]  <fox2mike> bear: audit across DCs, all kvm hosts should be in inventory
(Assignee)

Comment 1

6 years ago
fox2mike named them ns1a and ns1b when he installed them, so I'm surprised he couldn't find them in inventory. ns1 is just a vip that floats between those machines, not a machine itself so it doesn't have an inventory entry.
Assignee: server-ops-releng → arich
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
And for the record, all KVM hosts *are* in inventory.  Kickstarting them requires it, after all.
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.