a role="navigation" attribute is missing on the nav element

VERIFIED FIXED in 2012-07-12

Status

Marketplace
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: icaaq, Assigned: cvan)

Tracking

({access})

2012-07-12
access
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120618030531

Steps to reproduce:

1. Press Cmd+N to open a new browser window, then type https://marketplace.mozilla.org/en-US/ in the address bar and press Enter
2. Inspect #site-header > section > nav


Actual results:

The nav element is missing a role="navigation" attribute.


Expected results:

As Steve Faulkner says[http://www.paciellogroup.com/blog/2012/06/html5-accessibility-chops-when-to-use-an-aria-role/]:

It will be years before New HTML5 elements get robust accessibility support implemented across browsers and platforms. This is particularly so for non interactive elements such as the new HTML5 structural elements because  accessibility APIs in general do not have defined roles for many non interactive elements. In this case it is recommended to add the appropriate ARIA roles to elements that are meant to convey meaning but are effectively meaningless due to lack of implemented accessibility support.
For example, adding role=navigation to a nav element fills the gaps in support for HTML5 semantics as ARIA  is more robustly  supported by most modern browsers and assistive technology:

<nav role=”navigation”>
(Reporter)

Updated

6 years ago
Keywords: access
(Assignee)

Comment 1

6 years ago
https://github.com/mozilla/zamboni/commit/94faf83
Assignee: nobody → cvan
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-07-12

Comment 2

6 years ago
verified fixed.
Status: RESOLVED → VERIFIED

Comment 3

6 years ago
Created attachment 640669 [details]
post-fix screenshot
You need to log in before you can comment on or make changes to this bug.