Alert dialogs crash when I hit ok.

RESOLVED FIXED in M7

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: davidm)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

using davidm's new nsINetSupportDialogService, an alert dialog will crash when I
hit OK.

I've got the fix and I'm going to check it in.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
fixed.  the problem was in nsNetSupportDialog.cpp

here's the diff that I checked in:
Index: nsNetSupportDialog.cpp
===================================================================
RCS file: /cvsroot/mozilla/xpfe/appshell/src/nsNetSupportDialog.cpp,v
retrieving revision 1.8
diff -r1.8 nsNetSupportDialog.cpp
407c407,408
<       *mReturnValue = kOKButton;
---
>   if ( mReturnValue )
>     *mReturnValue = kOKButton;
(Assignee)

Comment 2

19 years ago
*** Bug 7662 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
code level fix, marking verified.

Comment 4

18 years ago
This is happening for me again on Netscape6/PR3 (Linux x86) will attach sample
HTML to cause crash
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 5

18 years ago
Created attachment 17330 [details]
test case for crash on NS6/PR3 (Linux x86)
yes, I see the crash in PR3.

it looks like it is fixed for RTM, since I don't get the crash anymore.

marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.