<map> causes extra whitespace; shouldn't be displayed

VERIFIED FIXED in M8

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: allen.sam, Assigned: peterl-retired)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: simple fix included, URL)

(Reporter)

Description

20 years ago
The <map> tag at the top of http://www.mozilla.org/ is causing there to be
extra whitespace at the top of the page. The fix for this is very easy.

Add, to ua.css,

map {display: none; }

Voila! Whitespace is gone, on mozilla.org and the other pages that exhibit this
flaw. This does not cause any functionality of the tag to be lost.

Someone check this in, that whitespace has been bothering me for a long time.
(Reporter)

Updated

20 years ago
Whiteboard: simple fix included

Updated

20 years ago
Assignee: rickg → kipp

Comment 1

20 years ago
Kipp -- this looks to be a box/line collapsing bug. Note the first blank line
that preceeds the map (at the very top of the page).
Component: Layout → Style System
The problem is actually that MAP is currently not mentioned in ua.css, so it
defaults to being an inline element. It thus creates an anonymous block box
around itself, takes note of itself because it is empty, and leaves a blank
line. This is correct as per CSS.

To follow HTML4, it should be declared like this:

   MAP { display: block; }

It would be wrong to say "map { display: none; }", because otherwise block-level
content in MAP elements would dissapear. See HTML4, section 13.6.1.

I am reassigning this to Style System.

Peter: The fix for this is really simple, just add the line mentioned above
to ua.css, near the AREA rule.
Assignee: kipp → peterl
Reassigning...
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M8
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
OK.Checked with the 6/23 build. Marking as verified fixed.
*** Bug 8846 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

20 years ago
*** Bug 9273 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.