Last Comment Bug 766002 - B2G RIL on Otoro: TypeError: networkTuple is null
: B2G RIL on Otoro: TypeError: networkTuple is null
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Other Branch
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla16
Assigned To: Marshall Culpepper [:marshall_law]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 18:29 PDT by Philipp von Weitershausen [:philikon]
Modified: 2012-06-22 03:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
networkTuple error fix - v1 (2.94 KB, patch)
2012-06-20 10:35 PDT, Marshall Culpepper [:marshall_law]
philipp: review+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2012-06-18 18:29:15 PDT
Seeing this in the logcat a couple of times:

  I/Gecko   (  115): RIL Worker: Error processing operator tuple: TypeError: networkTuple is null

Operator name and network status seem to be reported correctly; at least eventually. But it seems there's still some state confusion in there somewhere.
Comment 1 Marshall Culpepper [:marshall_law] 2012-06-20 10:35:32 PDT
Created attachment 634970 [details] [diff] [review]
networkTuple error fix - v1

The REQUEST_OPERATOR handler no longer tries to parse the network tuple when the returned operator data is NULL (i.e. not currently registered with any operator)

Also moved code into a new _processOperator function for consistency / separation.
Comment 2 Philipp von Weitershausen [:philikon] 2012-06-20 16:48:25 PDT
Comment on attachment 634970 [details] [diff] [review]
networkTuple error fix - v1

Nice! r=me

I haz a sad because not testable with emulator rite nao. :'(
Comment 3 Marshall Culpepper [:marshall_law] 2012-06-21 07:42:07 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #2)
> 
> I haz a sad because not testable with emulator rite nao. :'(

Yeah.. unfortunately the emulator's network selection doesn't seem to ever change an operator from being "available", even if it is the current selection (or if there is no selection at all). This could probably be fixed, but it would take a fair amount of code.

IMO, it might make more sense to start trying to figure out how to use mock-ril..
Comment 4 Philipp von Weitershausen [:philikon] 2012-06-21 12:00:39 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f86277e8b787
Comment 5 Philipp von Weitershausen [:philikon] 2012-06-21 12:02:19 PDT
(In reply to Marshall Culpepper [:marshall_law] from comment #3)
> IMO, it might make more sense to start trying to figure out how to use
> mock-ril..

+1

It's in JS, too!
Comment 6 Ed Morley [:emorley] 2012-06-22 03:45:47 PDT
https://hg.mozilla.org/mozilla-central/rev/f86277e8b787

Note You need to log in before you can comment on or make changes to this bug.