Last Comment Bug 766007 - Create scrollframes for frameset documents
: Create scrollframes for frameset documents
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 19:10 PDT by Robert O'Callahan (:roc) (email my personal email if necessary)
Modified: 2012-10-30 17:49 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.54 KB, patch)
2012-06-18 19:12 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
tnikkel: review+
Details | Diff | Splinter Review

Description Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-18 19:10:31 PDT
We might as well. Framesets aren't common, the optimization of avoiding scrollframes is insigificant, and it simplifies things across mobile and desktop and reduces the number of different code paths.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-18 19:12:05 PDT
Created attachment 634269 [details] [diff] [review]
fix
Comment 2 Timothy Nikkel (:tnikkel) 2012-06-18 21:34:40 PDT
Comment on attachment 634269 [details] [diff] [review]
fix

I guess content can't do anything silly like create scrollbars by applying an overflow style or something to the root or body element?
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-20 17:47:06 PDT
It actually can; html.css has "frameset { overflow: -moz-hidden-unscrollable; }", so content can override it. However, I think that's a feature. Note that currently content can add scrollframes to non-root <frameset>s.
Comment 4 Timothy Nikkel (:tnikkel) 2012-06-20 22:44:38 PDT
Comment on attachment 634269 [details] [diff] [review]
fix

Ok.
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-21 22:11:46 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/419f0d1b848b
Comment 6 Mounir Lamouri (:mounir) 2012-06-22 02:16:21 PDT
Backed out due to perma orange on Moth, see:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=8661c74deeb5

https://hg.mozilla.org/integration/mozilla-inbound/rev/ef1c6a327b0d
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-22 03:55:30 PDT
This didn't seem to be the cause of the orange. Relanded:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e828ff0dbc94
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-06-23 05:48:07 PDT
https://hg.mozilla.org/mozilla-central/rev/e828ff0dbc94

Note You need to log in before you can comment on or make changes to this bug.