If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Access the cache files in \Temp\plugtmp

VERIFIED WONTFIX

Status

()

Firefox
Untriaged
VERIFIED WONTFIX
5 years ago
5 years ago

People

(Reporter: Hervé Guéret, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28 ( .NET CLR 3.5.30729; .NET4.0E)
Build ID: 20120306064154

Steps to reproduce:

I use 3.6 versions because it is impossible, with more recent versions, to access the cache files with programs such as Excel VBA. 
Can you update the last versions to make this possible again ?


Actual results:

I am playing with a game from http://www.virtualregatta.com.
This game writes files in the cache directory
I:\Documents and Settings\Hervé\Local Settings\Temp\plugtmp
if I use 3.6 version, not earliest. Except if HTTPFox add-on is in use, but it slow down the machine too much.


Expected results:

Files avalaible en the cache for other programs.

Comment 1

5 years ago
(In reply to Hervé Guéret from comment #0)
> I use 3.6 versions because it is impossible, with more recent versions, to
> access the cache files with programs such as Excel VBA. 

Which recent version did you test?
Summary: Obliged to use 3.6 FireFox version → Access the cache files in \Temp\plugtmp
Temporary plugin files are now stored inside the normal disk cache (AFAIK) and it's no design goal to make possible to access this files with external applications
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 3

5 years ago
You can give this cache viewer addon a try:
https://addons.mozilla.org/en-US/firefox/addon/cacheviewer-continued/
Status: RESOLVED → VERIFIED

Comment 4

5 years ago
Another (Windows) utility worth investigating, Nirsoft's:

"MozillaCacheView - View the cache files of Mozilla/Firefox browsers"
http://www.nirsoft.net/utils/mozilla_cache_viewer.html

PS: %TMP% should be readable & writable (perhaps a parent directory permissions [hidden?] issue) & is not the normal location for /Cache/ anyhow, though it does still seem to be used for plugtmp-# & it appears that some odd "cache" files end up there too, perhaps incompletely loaded files may reside in both %TMP% & /Cache/?.
(Reporter)

Comment 5

5 years ago
Hello Andre Klapper, I believe it is not possible anymore, including with the last ones. It's a pitty, because il was very usufull. In fact, the plugtmp directory does not exist anymore.

Matthias, yes, they are in the normal disk cache, but their names are masked, so it is impossible to open them.
It's obvious they are there, because they can be seen, and read, with the HTTPFox add-on.
It is also strange than some of those files were 2 years ago in the plugtmp cache, and have migrated now in the normal cache, as if the internet game program could pilot in witch part of the cache they want to put the files, type by type.
You need to log in before you can comment on or make changes to this bug.