[debugger] ctrl-tab doesn't switch to a new tab when one of the panels is focused

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120706])

Comment hidden (empty)
Paul does that happen when the debuggee is paused or even when the debuggee is running?
(Reporter)

Comment 2

5 years ago
When the "play" button is pressed.
Joe faced a similar issue in the developer toolbar and fixed it like this:
https://hg.mozilla.org/integration/fx-team/rev/bd9789163a5f

Maybe we are focusing the debugger after a pause and could stop doing that.

Comment 4

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120705 Firefox/15.0a2 (20120705042010)

This is an intermittent issue.

STR:
1. Load a web page in the browser (e.g. http://greensqr.com/misc/mozilla/debugger/).
2. Open the Debugger.
3. Try to use some of the browser specific shortcuts (Ctrl+Tab, Ctrl+T, Ctrl+Shift+A, Ctrl+F etc).
4. Click on the URL bar or tab titlebar to remove the focus from the Debugger. (I also tried clicking on the web page).

Some times no shortcuts work. Other times, with the same STR, all the shortcuts work.
Whiteboard: [testday-20120706]
Priority: -- → P3
(In reply to Panos Astithas [:past] from comment #3)
> Joe faced a similar issue in the developer toolbar and fixed it like this:
> https://hg.mozilla.org/integration/fx-team/rev/bd9789163a5f
> 
> Maybe we are focusing the debugger after a pause and could stop doing that.

This is definitely the cause.

However, not focusing the debugger after a pause would make all the keyboard shortcuts (including the ones related to stepping) not work, since they're defined in debugger.xul. I believe this is a much bigger issue than not being able to access some browser shortcuts.

And there's always TAB to move the focus back to content or chrome :)

I would mark this bug as WONTFIX, but I'd like to hear other opinions.
I think we are now dynamically attaching the toolbox keybindings to the chrome window when the toolbox opens. Can't we do the same here?
(In reply to Panos Astithas [:past] from comment #6)
> I think we are now dynamically attaching the toolbox keybindings to the
> chrome window when the toolbox opens. Can't we do the same here?

That would probably be a bad idea, since there are too many debugger shortcuts that overlap with default browser shortcuts (e.g. accel+B and accel+shift+B for adding breakpoints vs. opening bookmarks, F6 for resume vs. focusing the awesomebar, F7 for step over vs. turning caret browsing on or off.. it's a long list, I'll stop here).
Ok!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.