Menu contents vary depending on how you open it

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Wild Willy Kredentser, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Using the mouse, click on the File entry in the Menu Bar.  Options in the menu are:
New Tab
New Window
Open File...
Save Page As...
Send Link...
Page Setup...
Print Preview
Print...
Work Offline
Exit

Now open the same menu without the mouse, using only the keyboard, by clicking & releasing Alt, then pressing DownArrow.  Options in the menu are:
New Tab
New Window
Open Location  <-- not in list above
Open File...
Close  <-- not in list above (if window is just one Tab)
Save Page As...
Send Link...
Page Setup...
Print Preview
Print...
Work Offline
Exit

If you have multiple Tabs open in the browser window, dropping down the File menu mouselessly displays two entries instead of just Close:
Close Tab
Close Window



Expected results:

The way you open the menu should not affect what entries are in the menu.  The Close or Close Tab/Close Window entry(s) should be there either way.
This is by Design. See Bug 626825.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
Sorry.  During the initial bug creation, there was a list of similar bugs that got shown before I went ahead & created this one.  I don't think (I could be wrong) 626825 appeared in the list, nor any of the ones mentioned in there.  I have read through several of them, hardly understanding the code discussion at all, but understanding now that you are trying to eliminate menu items that are available via other methods on the screen.  I suppose it's a philosophical discussion of how much redundancy is enough & how much is too much.  Now that I understand what you were going for, I can see the sense of what you did.  I'm not sure I totally agree, but I understand.  I'm still not completely sold on keyboard vs mouse activation being the factor that determines what is considered redundant.  And I don't get why the Linux guys in particular were so anxious to roll this into the product.  But I suppose I can safely go to my grave never learning the secrets behind these mysteries.

Again, sorry I cluttered up the world with this redundant bug report.
There's no Need to excuse for filing proper Bug Reports as you did :-)

And, the Dupe Detection on Bug Filing is only as good as the Terms used in a Bug's Summary Line.
You need to log in before you can comment on or make changes to this bug.