seamonkey corrupts pdf while loading

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Ken Wilson, Unassigned)

Tracking

SeaMonkey 2.10 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20120615 Firefox/13.0.1 SeaMonkey/2.10.1
Build ID: 20120615050225

Steps to reproduce:

Viewed PDF from web site as usual.


Actual results:

PDF download but loads incompletely with errors, reporting that PDF is corrupt.


Expected results:

Should have loaded correctly. Subsequent test with firefox 13.1 works fine using same Adobe application (acrobat pro 9.5.1 or reader plugin, same results). PDF link is at http://www.cccc.ca/#/calendar/conference-registration. This corruption appears to be seamonkey specific and recent.

Comment 1

6 years ago
I clicked the link to the PDF which loaded this page:

> http://storage.cloversites.com/congregationalchristianchurchesincanada/documents/2012%20Conference%20Brochure_2.pdf

NoScript blocked the load of the PDF, showing only a placeholder.
At that point I downloaded the PDF though my download manager, directly.
Again the PDF had not actually loaded at that point.

Then I clicked the placeholder & the PDF loaded within my browser window, via the Adobe PDF Plug-In For Firefox and Netscape 10.1.3.23.  From there I saved a copy of the PDF (through Adobe Reader, Save function) to my disk.

Both copies compared exactly & displayed as expected & are the same as is displayed in my browser window.

MD5 hash of the PDF (538,575 bytes):  eaa236f7fa4a07139bfb58a84e0129bd
(Reporter)

Comment 2

6 years ago
Very strange. Running the same version of Adobe Reader (I updated to be sure) and the latest seamonkey we start out the same with NoScript placeholder. However, when I allow the pdf to display by clicking the placeholder Reader displays its blue progress bar and then leaves town. the progress bar just freezes about 10% in to the download and no pdf displayed. Under firefox everything works perfectly.
(Reporter)

Comment 3

6 years ago
Okay, it was hanging because seamonkey was not displaying the initial Adobe install license agreement screen. Now that it would of way, all is well. Possibly it was the previous version of Acrobat Reader that was the problem. However, it showed as current. I had to retrieve and install the newer version.

Comment 4

6 years ago
WFM per Comment 3.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.