Intermittent browser_dbg_createChrome.js | Test timed out | uncaught JS exception - ReferenceError: ok is not defined at browser_dbg_createChrome.js:80

RESOLVED FIXED in Firefox 22

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: emorley, Assigned: past)

Tracking

({intermittent-failure})

15 Branch
Firefox 22
x86_64
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 634422 [details]
Screenshot

Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora opt test mochitest-other on 2012-06-15 23:26:58 PDT for push ac587e102ae8

slave: talos-r4-snow-004

https://tbpl.mozilla.org/php/getParsedLog.php?id=12722676&tree=Mozilla-Aurora

{
TEST-START | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger process wasn't created properly!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger process isn't running!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger process doesn't have a pid (?!)
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | process location: undefined
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | process pid: 402
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | process name: undefined
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | process sig: undefined
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile wasn't created properly!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile doesn't have a localDir...
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile doesn't have a rootDir...
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile doesn't have a name...
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile localDir: [xpconnect wrapped nsILocalFile]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile rootDir: [xpconnect wrapped nsILocalFile]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile name: _remote-debug_remote-debug
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile wasn't *actually* created properly!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile doesn't have the correct localDir!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger profile doesn't have the correct rootDir!
2012-06-15 23:45:33.953 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x1159dbf10 of class NSTrackingArea autoreleased with no pool in place - just leaking
2012-06-15 23:45:33.955 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x118578f10 of class NSTrackingArea autoreleased with no pool in place - just leaking
2012-06-15 23:45:33.956 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x1188d47c0 of class NSCFArray autoreleased with no pool in place - just leaking
2012-06-15 23:45:33.957 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x1188d4820 of class NSCFArray autoreleased with no pool in place - just leaking
2012-06-15 23:45:33.977 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x7fff7079d590 of class NSCFString autoreleased with no pool in place - just leaking
2012-06-15 23:45:33.982 firefox-bin[402:903] *** __NSAutoreleaseNoPool(): Object 0x7fff707989b0 of class NSCFString autoreleased with no pool in place - just leaking
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger process isn't closed as it should be!
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | The remote debugger process didn't die cleanly.
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | process exit value: 256
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile localDir: /Users/cltbld/Library/Caches/Firefox/Profiles/zfxr1d03._remote-debug_remote-debug
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile rootDir: /Users/cltbld/Library/Application Support/Firefox/Profiles/zfxr1d03._remote-debug_remote-debug
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | profile name: _remote-debug_remote-debug
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | Test timed out
args: ['/usr/sbin/screencapture', '-C', '-x', '-t', 'png', '/var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/mozilla-test-fail_aPDagy']
SCREENSHOT: <attached>
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | finished in 120558ms
TEST-INFO | checking window state
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | an unexpected uncaught JS exception reported through window.onerror - ReferenceError: finish is not defined at chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js:80
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 994
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
}
(Reporter)

Updated

6 years ago
Version: Trunk → 15 Branch
(Assignee)

Updated

6 years ago
Priority: -- → P3
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Would love to know which changeset caused this test to start failing so frequently...
Comment hidden (Treeherder Robot)

Updated

5 years ago
Summary: Intermittent browser_dbg_createChrome.js | Test timed out | uncaught JS exception - ReferenceError: finish is not defined at browser_dbg_createChrome.js:80 → Intermittent browser_dbg_createChrome.js | Test timed out | uncaught JS exception - ReferenceError: ok is not defined at browser_dbg_createChrome.js:80
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 93

5 years ago
Created attachment 720706 [details] [diff] [review]
Moar logging

(In reply to Victor Porof [:vp] from comment #59)
> Would love to know which changeset caused this test to start failing so
> frequently...

I bet it's not a devtools-related change. Hopefully adding more logging would help pinpoint the cause of the timeout.
Assignee: nobody → past
Status: NEW → ASSIGNED
Attachment #720706 - Flags: review?(vporof)
Comment on attachment 720706 [details] [diff] [review]
Moar logging

Review of attachment 720706 [details] [diff] [review]:
-----------------------------------------------------------------

Sure!
Attachment #720706 - Flags: review?(vporof) → review+
(Assignee)

Updated

5 years ago
Whiteboard: [leave open]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 721085 [details] [diff] [review]
Longer timeout

With the additional logging it looks more like general slowness, than anything else. Increasing the timeout for the test should help.
https://hg.mozilla.org/mozilla-central/rev/b3fece5dfefd
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.