Intermittent OOM in browser_gcli_pref.js | uncaught JS exception - NS_ERROR_OUT_OF_MEMORY: Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDOMHTMLCanvasElement.mozFetchAsStream] at resource:///modules/PageThumbs.jsm:98

RESOLVED DUPLICATE of bug 763998

Status

()

Firefox
Developer Tools
--
critical
RESOLVED DUPLICATE of bug 763998
6 years ago
5 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

15 Branch
x86
Linux
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Rev3 Fedora 12 mozilla-aurora pgo test mochitest-other on 2012-06-16 06:19:21 PDT for push ac587e102ae8

slave: talos-r3-fed-076

https://tbpl.mozilla.org/php/getParsedLog.php?id=12728405&tree=Mozilla-Aurora

{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_pref.js | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_OUT_OF_MEMORY: Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDOMHTMLCanvasElement.mozFetchAsStream] at resource:///modules/PageThumbs.jsm:98
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 994
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_pref.js | Console message: [JavaScript Error: "NS_ERROR_OUT_OF_MEMORY: Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDOMHTMLCanvasElement.mozFetchAsStream]" {file: "resource:///modules/PageThumbs.jsm" line: 98}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_pref.js | Console message: [JavaScript Error: "out of memory" {file: "resource:///modules/sessionstore/SessionStore.jsm" line: 4110}]
out of memory
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_pref.js | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:10:42.216029
INFO | automation.py | Reading PID log: /tmp/tmpp9rcLLpidlog
==> process 2537 launched child process 2587
INFO | automation.py | Checking for orphan process with PID: 2587
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1339845606/firefox-15.0a2.en-US.linux-i686.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_gcli_pref.js | application crashed (minidump found)
Crash dump filename: /tmp/tmpU8D39z/minidumps/573f82df-769e-2bc1-279ac594-6fc6ebd5.dmp
Operating system: Linux
                  0.0.0 Linux 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 0 (crashed)
 0  libmozalloc.so!TouchBadMemory [mozalloc_abort.cpp:ac587e102ae8 : 35 + 0x0]
    eip = 0x00309f4c   esp = 0xbfb979ac   ebp = 0x0acbd400   ebx = 0x0030b1d8
    esi = 0x00c59844   edi = 0x0acbd400   eax = 0x0000000a   ecx = 0x0030b1d8
    edx = 0x00c5a32c   efl = 0x00010206
    Found by: given as instruction pointer in context
 1  libmozalloc.so!mozalloc_abort [mozalloc_abort.cpp:ac587e102ae8 : 56 + 0x4]
    eip = 0x00309f97   esp = 0xbfb979b0   ebp = 0x0acbd400   ebx = 0x0030b1d8
    esi = 0x00c59844   edi = 0x0acbd400
    Found by: call frame info
 2  libmozalloc.so!mozalloc_handle_oom [mozalloc_oom.cpp:ac587e102ae8 : 27 + 0xd]
    eip = 0x0030a000   esp = 0xbfb979d0   ebp = 0x0acbd400   ebx = 0x0030b1d8
    esi = 0x00000ffc   edi = 0x0acbd400
    Found by: call frame info
 3  libmozalloc.so!moz_xmalloc [mozalloc.cpp:ac587e102ae8 : 56 + 0x7]
    eip = 0x00309bce   esp = 0xbfb979f0   ebp = 0x0acbd400   ebx = 0x0030b1d8
    esi = 0x00000ffc   edi = 0x0acbd400
    Found by: call frame info
 4  libxul.so + 0x6492e5
    eip = 0x015d62e6   esp = 0xbfb97a10   ebp = 0x0acbd400   ebx = 0x02845c48
    esi = 0x076c7ec0   edi = 0x0acbd400
    Found by: call frame info
 5  libxul.so + 0x18b8c47
    eip = 0x02845c48   esp = 0xbfb97a30   ebp = 0x0acbd400
    Found by: stack scanning
 6  libnspr4.so!PR_GetCurrentThread [ptthread.c:ac587e102ae8 : 577 + 0x8]
    eip = 0x009ad0e9   esp = 0xbfb97a64   ebp = 0x0acbd400
    Found by: stack scanning
 7  libxul.so + 0x18b8c47
    eip = 0x02845c48   esp = 0xbfb97a68   ebp = 0x0acbd400
    Found by: stack scanning
 8  libxul.so + 0xb42187
    eip = 0x01acf188   esp = 0xbfb97a70   ebp = 0x0acbd400
    Found by: stack scanning
 9  libxul.so + 0x18b8c47
    eip = 0x02845c48   esp = 0xbfb97a74   ebp = 0x0acbd400
    Found by: stack scanning
10  libxul.so + 0x135f5de
    eip = 0x022ec5df   esp = 0xbfb97a80   ebp = 0x0acbd400
    Found by: stack scanning
}
(Reporter)

Comment 1

6 years ago
Guess dupe of bug 763998?
Summary: Intermittent browser_gcli_pref.js | uncaught JS exception - NS_ERROR_OUT_OF_MEMORY: Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDOMHTMLCanvasElement.mozFetchAsStream] at resource:///modules/PageThumbs.jsm:98 (+crash) → Intermittent OOM in browser_gcli_pref.js | uncaught JS exception - NS_ERROR_OUT_OF_MEMORY: Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDOMHTMLCanvasElement.mozFetchAsStream] at resource:///modules/PageThumbs.jsm:98
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
Severity: normal → critical
(Reporter)

Updated

6 years ago
Version: Trunk → 15 Branch
Comment hidden (Treeherder Robot)
Depends on: 768534
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Blocks: 777727
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763998
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.