Too much space above and below line with zero-width space (U+200B) when using specific fonts on Win XP

RESOLVED DUPLICATE of bug 739804

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 739804
6 years ago
3 years ago

People

(Reporter: Loic, Unassigned)

Tracking

({regression, testcase})

13 Branch
x86_64
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Some users reported this issue with Firefox 13 (beta & release) on Windows XP only.
When a line contains the zero-width space (U+200B) [1] with specific fonts (Times New Roman, Verdana etc), there is too much space above and below the line.

Restarting FF13 in safe mode or using a new profile doesn't fix the issue.
Downgrading to FF12 fixes the issue.
Changing the default font may fix the issue (like switching to MS Sans Serif or DejaVu Serif).

This issue is *not* reproducible with all FF13 running on Win XP (Nvidia or ATI GPUs). Maybe GDI and the font rendering are involved.
I tried to modify some settings in about:config to try to reproduce the bug on Win 7 but I failed.

I'd say it's a regression of Bug 729047.

[1] http://en.wikipedia.org/wiki/Zero-width_space
(Reporter)

Updated

6 years ago
Component: Untriaged → Layout: Text
OS: Windows 7 → Windows XP
Product: Firefox → Core
(Reporter)

Comment 1

6 years ago
Created attachment 634435 [details]
Testcase with fonts Times New Roman, Verdana and MS Sans Serif

Testcase:

3 fonts are tested: Times New Roman, Verdana and MS Sans Serif
For each font:
+ 1st line is without the zero-width space between each sequence
+ 2nd line contains the zero-width space between each sequence

2nd line with MS Sans Serif should be normal with no extra space above and below.
(Reporter)

Updated

6 years ago
Attachment #634435 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 2

6 years ago
Created attachment 634440 [details]
Snapshot of bug

I upload a snapshot of the bug visible on a discussion board.
Each user's nickname contains a zero-width space after the 10th letter to be cut when the browser window is shortened. You can see that nicknames with 11 letters or more have space above and below.
(Reporter)

Updated

6 years ago
Keywords: regression, regressionwindow-wanted, testcase

Comment 3

6 years ago
This is bug 739804 I think.
(Reporter)

Comment 4

6 years ago
(In reply to mjh563 from comment #3)
> This is bug 739804 I think.

I'm not sure because it appears (afaik) only on Win XP (and maybe with old drivers). Even with gfx.direct2d.disabled = true on Win 7, the issue is not visible.

Comment 5

6 years ago
Is it reproducible in the current Nightly?
(Reporter)

Updated

6 years ago
QA Contact: untriaged → layout.fonts-and-text
The issue might not appear on Win7 because the OS ships with more complete versions of the core fonts, and so font fallback might not kick in for the ZWSP character. So it's entirely plausible that an instance of bug 739804 might show up only on WinXP, and not on Win7 even without D2D.
(Reporter)

Comment 7

6 years ago
More info: some users tried FF16 and FF14, and the bug was fixed, so this bug is likely a dupe of bug 739804.
Yup, I'm pretty sure this was another example of 739804. Marking as dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 739804
(Reporter)

Comment 9

6 years ago
Created attachment 638689 [details]
Times New Roman and Verdana fonts

For the record, I attached a font pack (Times New Roman and Verdana) provided by a user who's meeting this issue on Win XP SP3. They are old fonts (2001 & 2004) but on my Win 7 and XP SP3 machines, with these 2 fonts installed, I wasn't able to reproduce it, with or without D2D.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.