install.rdf fails validation during upload

VERIFIED FIXED in 2012-06-21

Status

addons.mozilla.org Graveyard
Add-on Validation
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: kinger, Unassigned)

Tracking

unspecified
2012-06-21
x86
All

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I'm trying to upload a new version of one of my add-ons. install.rdf fails to validation, thus it fails. Nothing has changed in install.rdf except the version number, since the last successful upload. It installs and works fine.

Message is:

Your add-on failed validation with 1 error.
Could not parse install.rdf

Here is the XPI:
https://dl.dropbox.com/u/5940796/facebook/facebook1-8-2.xpi

Comment 1

6 years ago
This runs fine locally, so it leads me to believe that it's being unpacked wrong on the Zamboni side.
This is happening for many different add-ons, so it's most likely a server problem.

Comment 3

6 years ago
I suspect this to be the cause:

https://github.com/mozilla/zamboni/blob/master/apps/files/utils.py#L395

Can we get a look at the logs?
The exception is:

files.utils:ERROR XPI parse error :/data/www/addons.mozilla.org/zamboni/apps/files/utils.py:396#012Traceback (most recent call last):#012  File "/data/www/addons.mozilla.org/zamboni/apps/files/utils.py", line 389, in parse_xpi#012    rdf = Extractor.parse(path)#012  File "/data/www/addons.mozilla.org/zamboni/apps/files/utils.py", line 86, in parse#012    return cls(install_rdf).data#012  File "/data/www/addons.mozilla.org/zamboni/apps/files/utils.py", line 70, in __init__#012    'install.rdf')))#012  File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/rdflib/graph.py", line 757, in parse#012    parser.parse(source, self, **args)#012  File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/rdflib/plugins/parsers/rdfxml.py", line 562, in parse#012    self._parser = create_parser(source, sink)#012  File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/rdflib/plugins/parsers/rdfxml.py", line 540, in create_parser#012    parser = make_parser()#012  File "/usr/lib64/python2.6/xml/sax/__init__.py", line 93, in make_parser#012    raise SAXReaderNotAvailable("No parsers found", None)#012SAXReaderNotAvailable: No parsers found


who knows what it's trying to import though. Seems like some standard module is missing.
Looks like we had an unexpected Python upgrade on some servers. Jason is downgrading which should fix it.
Downgraded python on addons nodes to previous version python-2.6.6-29.el6.x86_64. Pinned puppet configuration to this version.
Brian, Jorge, did that fix it?

Comment 8

6 years ago
Working for me now.
Thanks, reopen if anyone runs into something
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-06-21
(Reporter)

Comment 10

6 years ago
WFM now as well.
Status: RESOLVED → VERIFIED

Comment 11

6 years ago
I'm getting the same problem.

"Your add-on failed validation with 1 error.
Add-on missing install.rdf."

The only thing I changed since my last upload is the version number.  Here is my rdf file if you'd like to see it: http://www.bettercdcs.com/install.rdf
Have you tried uploading recently?

Comment 13

6 years ago
I tried a few minutes ago.  That was when I got the error with the rdf file.

Comment 14

6 years ago
Can you attach the XPI?

Comment 15

6 years ago
Created attachment 635008 [details]
better cdcs xpi file
(In reply to harryledley from comment #11)
> "Your add-on failed validation with 1 error.
> Add-on missing install.rdf."

Hello. This message is not the same as the message originally reported in this bug. "Add-on missing install.rdf" means exactly what it says. I looked at the add-on you attached and indeed it does not have the install.rdf in the right place. It is in a subdirectory but you need to put it in the main directory of the zipped xpi because that's where Firefox looks for it.

If you still have trouble with it after fixing your XPI please open another bug since it is a separate issue.

Comment 18

6 years ago
Ah, yes.  Thanks.  That fixed the problem.  Sorry for bothering for such a small thing.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.