Closed Bug 766207 Opened 10 years ago Closed 10 years ago

Unable to launch Persona to log into Marketplace app

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: krupa.mozbugs, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot
This is related to bug 742944. I was asked by Dietrich to file a new bug.

steps to reproduce:
1. Launch Marketplace app on your b2g device (zte)
2. Click on the Login button in the footer

expected behavior:
Persona window launches and user can log in

actual behavior:
The ajaxy spinner is seen but nothing happens. This blocks users from logging into Marketplace app AND purchasing apps.

Build details:
Gaia
* commit 3a6dfbc2ae601dfcbbc2411e137bef2a61190710
Merge: 158470d 957c0c9
Author: vingtetun <21@vingtetun.org>
Date:   Tue Jun 19 09:36:35 2012 -0700

Gecko
* commit 953ff26477fc11bcda76f22c4e5647b2bcee92d2
Merge: cf0def7 cfb2dbb
Author: Michael Wu <mwu@mozilla.com>
Date:   Thu Jun 14 20:41:21 2012 -0700
This is not a Gecko bug.  This feature has not been implemented in Gaia yet.  Here's the e-mail I wrote to Faramarz about this:

The necessary changes have not landed in Gaia yet.

Etienne tells me:

<etienne_s> jlebar: the only implementations are currently for
window.open(*, *, 'attention') and window.open(*, *, 'background')

Dale and/or Ben plans to get to this soon for the browser; I'm not
sure they realized how many people we have beating down our door for
this.  :)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Justin, where is the bug to track this for Gaia?
No longer blocks: 766481
this will be solved by either window.open or, more likely, native navigator.id.
Justin, is this commit sufficient, or do we still need to wait for other stuff?

https://github.com/mozilla-b2g/gaia/pull/2021
(In reply to Bill Walker [:bwalker] [@wfwalker] from comment #5)
> Justin, is this commit sufficient, or do we still need to wait for other
> stuff?

That was the only thing we were waiting for.  But Etienne showed me a few hours ago that BrowserID crashes the browser when you try to log in on MDN with his patch, so there are likely other problems to solve.  Investigating is my top priority right now, but I can't promise a timeline at this point because (a) I have no idea what's going wrong and (b) I'm at the B2G work week, and we're having a number of important discussions, which cut into coding time.

I'll be sure to cc you on any bugs I file.
Blocks: 830998
You need to log in before you can comment on or make changes to this bug.