segfault when I visit a specific website

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: sam113101, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615233552

Steps to reproduce:

Clicked on a link.


Actual results:

It crashed. This is what I get when I open firefox from a terminal emulator and it crashes again:
###!!! ABORT: X_CopyArea: BadDrawable (invalid Pixmap or Window parameter); 19 requests ago: file /build/src/mozilla-release/toolkit/xre/nsX11ErrorHandler.cpp, line 190
###!!! ABORT: X_CopyArea: BadDrawable (invalid Pixmap or Window parameter); 19 requests ago: file /build/src/mozilla-release/toolkit/xre/nsX11ErrorHandler.cpp, line 190
Segmentation fault


Expected results:

The website should show without making my browser crash.

I'm using archlinux. The website started making firefox crash after an update. I think it only happens to me, other users seem to be fine browsing the website with firefox (maybe they aren't using the same OS as me).

This is the website:
http://www.chapatiz.com/bbs/

It's a phpbb forum, and it only crashes when I visit this section of the website. I just click on a link to a thread or to a forum and it randomly crashes. You don't need to be logged in to browse it or to experience the same bug.

If you need more information, like the plugins or add-ons I use, feel free to ask. I don't want to make it too long and I think I provided the necessary information.

Comment 1

6 years ago
Type about:crashes, click on crash reports and post the links here (if crash reports are present).
(Reporter)

Updated

6 years ago
Duplicate of this bug: 766302
(Reporter)

Comment 3

6 years ago
"The address isn't valid
The URL is not valid and cannot be loaded."
(Reporter)

Comment 4

6 years ago
It is not caused by a plugin, it crashes in safemode too.
(Reporter)

Comment 5

6 years ago
It wasn't caused by an add-on*. I think it was flash's fault because it doesn't crash when I use flashblock.

Comment 6

6 years ago
Safemode doesn't disable plugins, only add-ons and themes (+ other things).
You can disable the Flash plugin in about:addons and make a try. What's your Flash version?

Comment 7

5 years ago
Reporter, can you reproduce this with recent versions of the programs?  Thanks.
Flags: needinfo?(sam113101)
(Reporter)

Comment 8

5 years ago
(In reply to Aleksej [:Aleksej] from comment #7)
> Reporter, can you reproduce this with recent versions of the programs? 
> Thanks.

No, it doesn't happen anymore.
Flags: needinfo?(sam113101)

Comment 9

5 years ago
OK, thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.