Spacebar triggers button on release, should require press/release

VERIFIED DUPLICATE of bug 99777

Status

()

P4
trivial
VERIFIED DUPLICATE of bug 99777
18 years ago
16 years ago

People

(Reporter: neil, Assigned: saari)

Tracking

Trunk
mozilla1.0.1
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Using Build ID: 2001041704

Steps to reproduce problem:
1. Start reading news
2. Use space to scroll through message
3. At the end of the message, space will advance to the next unread message
4. At the end of the group, space will advance to the next unread group

Expected results: confirmation that you want to advance to the next unread group

Actual results: release of spacebar dismissis confirmation dialog

Additional information: I have tried setting the autorepeat delay to no avail.
I'd better set it back now. Having no autorepeat is annoying :-)

Alternative steps to reproduce problem:
1. Open preferences
2. Hold down space
3. Click and hold Cancel
4. Release space

Expected results: Cancel button still active

Actual results: dialog dismisses when space bar released

An unreleated problem:
1. Open preferences
2. Click and hold Cancel
3. Press and release space

Note that in this case the button had the focus when space was pressed.
It's still a bug but I mentioned it because the fix might be the same.

Comment 1

18 years ago
->saari/p4 for whenever
Assignee: trudelle → saari
Priority: -- → P4
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
(Reporter)

Comment 2

17 years ago
URL test case - space will show and usually promptly dismiss the alert...

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 99777 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Bah. This is so annoying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.