Closed Bug 766425 Opened 8 years ago Closed 7 years ago

Crash - GLControllerException :: EGL window surface could not created @ GLController.java:171

Categories

(Firefox for Android :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 763813
Tracking Status
firefox14 --- affected
firefox15 --- affected
firefox16 --- affected
blocking-fennec1.0 --- -
fennec + ---

People

(Reporter: aaronmt, Unassigned)

References

()

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash][gfx])

E/libEGL  ( 2800): eglCreateWindowSurface:358 error 300b (EGL_BAD_NATIVE_WINDOW)
W/System.err( 2800): org.mozilla.gecko.gfx.GLController$GLControllerException: EGL window surface could not be created! Error 12299
W/System.err( 2800): 	at org.mozilla.gecko.gfx.GLController.provideEGLSurface(GLController.java:171)
W/System.err( 2800): 	at dalvik.system.NativeStart.run(Native Method)
W/System.err( 2800): 	at dalvik.system.NativeStart.run(Native Method)
I/Gecko   ( 2800): ###!!! ABORT: We need a context on Android: file /builds/slave/m-in-andrd/build/gfx/layers/opengl/LayerManagerOGL.cpp, line 174
D/OpenGLRenderer( 2800): Flushing caches (mode 0)
I/ActivityManager(  192): Process org.mozilla.fennec (pid 2800) has died.
I/WindowManager(  192): WIN DEATH: Window{41b416c0 SurfaceView paused=false}
D/Zygote  (  119): Process 2800 terminated by signal (11)
I/WindowManager(  192): WIN DEATH: Window{41960430 org.mozilla.fennec/org.mozilla.fennec.App paused=false} I/WindowManager(  192): WIN DEATH: Window{41688e20 org.mozilla.fennec/org.mozilla.gecko.AwesomeBar paused=false}


STR:

adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d www.neowin.net
Severity: normal → critical
Ignore STR in comment #0

STR:

i) adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d www.neowin.net

ii) Hit your device home button

iii) adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d www.neowin.net
Summary: Crash - EGL window surface could not created → Crash - GLControllerException :: EGL window surface could not created @ GLController.java:171
Whiteboard: [native-crash] → [native-crash][gfx]
This crash was originally reported with STRs by the AppThwack support team. (Company background: http://blog.appthwack.com/sneak-peek-mobile-web-support)   

It actually blocks them from providing this testing service for Firefox Beta, aurora, and nightly.   The main reason being, their service moves firefox process to the background, while executing the STR.

Crash isn't reproducible on XUL.   It would be in good favor if we can find a fix and push this to the next .N release.

Thanks to aaron for dialoging with their support team to get this bug reproduced.
Dupe of bug 763813?
The problem is that step (iii) in the STR causes us to create a new widget (in addition to the widget that was created in step (i)), which in turn causes us to create a second compositor. Both compositors try to create EGL window surfaces, but we can only create one such surface, so the second one fails to create a surface, causing us to abort.

Probably the right solution to prevent a crash here is to use an EGL pbuffer surface for the second compositor. But this means that the second compositor won't be rendering to the screen (the first compositor will be rendering to the screen), so it's not clear that this solves AppThwack's problem.
tracking-fennec: ? → +
blocking-fennec1.0: ? → -
As far as my testing goes, I'm unable to reproduce this by any other means. Ali, is this reproducible outside of explicit activity launching via adb?
(In reply to Aaron Train [:aaronmt] from comment #5)
> As far as my testing goes, I'm unable to reproduce this by any other means.
> Ali, is this reproducible outside of explicit activity launching via adb?

I've only been able to reproduce it via adb.
This can also be reproduced with:

Intent i = new Intent();
i.setComponent(new  ComponentName("org.mozilla.firefox_beta","org.mozilla.firefox_beta.App"));
i.setData(Uri.parse('www.neowin.net'));
i.setAction("android.intent.action.VIEW");
startActivity(i);
Pretty sure I fixed this a while ago.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763813
You need to log in before you can comment on or make changes to this bug.