Cache isn't used when browsing session history

RESOLVED INVALID

Status

()

Core
Networking: Cache
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Si Ly, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When a page hasn't expired (or expiration date unknown?), Mozilla should load it
from the cache when the user is browsing session history, e.g. with the "back"
button.  Build 2001041808 reloads the page from the server.  It seems like it's
doing a plain GET request and doesn't even use If-modified-since.  For
performance reasons, I think it should just load it from the cache.

To reproduce:
1. Goto http://www.sily.net/cache-test.jsp
2. Click the "somewhere else" link.
3. Click the browser's "back" button.
4. Note that the page was refetched and the counter has incremented.

For more background/related information about this bug, see Bug #75098.
(Reporter)

Comment 1

17 years ago
I couldn't reproduce this on the Win32 build.  So, I went back to my Linux box
and deleted the Cache and NewCache directories.  And that fixes it!  Oh well, I
guess I'll just close this bug then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.