After last update Firefox is returning false mime-type for pdf files. It return "application/save" instead of "application/pdf".

RESOLVED DUPLICATE of bug 373621

Status

()

defect
RESOLVED DUPLICATE of bug 373621
7 years ago
7 years ago

People

(Reporter: sindijs, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

I created web form with file field. Web form allowed only pdf file types to upload.


Actual results:

Script couldnt safe file on disk because mime-type was false, although file was uploded as pdf. I checked mime-type, and it was "application/save" instead of "application/pdf'.


Expected results:

Mime-type must be "application/pdf" after pdf file was uploded.
This has nothing to do with the update.
You have downloaded once a file from a webserver that served a PDF file as application/save and you selected to remember that selection (e.g. open with Acrobat).

The wrong entry is stored in the file mimetypes.rdf in your Firefox profile.
To locate the profile enter about:support as URL in FF and use the link to your profile at the top. 
Close Firefox and remove the file or edit it to fix the issue...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621
You need to log in before you can comment on or make changes to this bug.