B2G desktop crash after click button in marketplace

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Thomasy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: b2g-desktop-builds)

Attachments

(6 attachments)

(Reporter)

Description

6 years ago
Created attachment 634927 [details]
未命名視窗_011.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120616053607

Steps to reproduce:

Go to marketplace click a item that is not free, log in using browser id later. I click on the "devoloper" button


Actual results:

It crashes.

$ gdb ../build/dist/bin/b2g -profile profile
gdb: unrecognized option '-profile'
Use `gdb --help' for a complete list of options.
liu@thomas-laptop:~/tmp/b2g/gaia$ gdb ../build/dist/bin/b2g                 
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/liu/tmp/b2g/build/dist/bin/b2g...done.
(gdb) run  -profile profile
Starting program: /home/liu/tmp/b2g/build/dist/bin/b2g -profile profile
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb4ad4b40 (LWP 16751)]
[New Thread 0xb403db40 (LWP 16752)]
[New Thread 0xb2dffb40 (LWP 16753)]
[New Thread 0xb23feb40 (LWP 16754)]
[New Thread 0xb17ffb40 (LWP 16755)]
[New Thread 0xb0dfeb40 (LWP 16756)]
[New Thread 0xafdffb40 (LWP 16757)]
[New Thread 0xaf0ffb40 (LWP 16758)]
[New Thread 0xae6feb40 (LWP 16759)]
[New Thread 0xad029b40 (LWP 16761)]
[New Thread 0x9ffffb40 (LWP 16762)]
[New Thread 0x9f1ffb40 (LWP 16763)]
[New Thread 0x9e1ffb40 (LWP 16764)]
======================= webapi.js ======================= 
[New Thread 0x9bfffb40 (LWP 16765)]
[New Thread 0x9b5feb40 (LWP 16766)]
[New Thread 0x9abfdb40 (LWP 16767)]
[New Thread 0x9a1fcb40 (LWP 16768)]
[New Thread 0x993ffb40 (LWP 16771)]
======================= webapi.js ======================= 
[New Thread 0x987ffb40 (LWP 16772)]
###################################### forms.js loaded
[New Thread 0x975ffb40 (LWP 16773)]
======================= webapi.js ======================= 
======================= webapi.js ======================= 
[New Thread 0x964ffb40 (LWP 16774)]
[Thread 0x9ffffb40 (LWP 16762) exited]
[New Thread 0x9ffffb40 (LWP 16775)]
[New Thread 0x91786b40 (LWP 16776)]
[New Thread 0x90d85b40 (LWP 16777)]
[Thread 0x964ffb40 (LWP 16774) exited]
======================= webapi.js ======================= 
[New Thread 0x964ffb40 (LWP 16779)]
[New Thread 0x901ffb40 (LWP 16780)]
[Thread 0xae6feb40 (LWP 16759) exited]
[New Thread 0xae6feb40 (LWP 16786)]
[New Thread 0x8f4ffb40 (LWP 16787)]
[New Thread 0x8eafeb40 (LWP 16788)]
*** UTM:SVC TimerManager:notify - notified @mozilla.org/browser/search-service;1
[Thread 0x9e1ffb40 (LWP 16764) exited]
[Thread 0x993ffb40 (LWP 16771) exited]
[Thread 0x91786b40 (LWP 16776) exited]
[Thread 0x8eafeb40 (LWP 16788) exited]
[Thread 0x901ffb40 (LWP 16780) exited]
*** UTM:SVC TimerManager:notify - notified @mozilla.org/addons/integration;1
[Thread 0x975ffb40 (LWP 16773) exited]
[New Thread 0x975ffb40 (LWP 16846)]

Program received signal SIGSEGV, Segmentation fault.
mozilla::BrowserElementParent::OpenWindowInProcess (aOpenerWindow=0xb7ade340, aURI=0x0, aName=..., aFeatures=..., aReturnWindow=0xbfffbca0)
    at /home/liu/tmp/b2g/src/dom/browser-element/BrowserElementParent.cpp:185
185	  aURI->GetSpec(spec);
(gdb) bt
#0  mozilla::BrowserElementParent::OpenWindowInProcess (aOpenerWindow=0xb7ade340, aURI=0x0, aName=..., aFeatures=..., aReturnWindow=0xbfffbca0)
    at /home/liu/tmp/b2g/src/dom/browser-element/BrowserElementParent.cpp:185
#1  0xb65ed7c5 in nsContentTreeOwner::ProvideWindow (this=0x9e64c760, aParent=0xb7ade340, aChromeFlags=4094, aCalledFromJS=false, aPositionSpecified=false, 
    aSizeSpecified=false, aURI=0x0, aName=..., aFeatures=..., aWindowIsNew=0xbfffbcd0, aReturn=0xbfffbca0)
    at /home/liu/tmp/b2g/src/xpfe/appshell/src/nsContentTreeOwner.cpp:856
#2  0xb65cdc7d in nsWindowWatcher::OpenWindowJSInternal (this=0xad7640a0, aParent=0xb7ade340, aUrl=0x0, aName=0xbfffbf3c "_blank", aFeatures=0x0, aDialog=false, argv=
    0x0, aCalledFromJS=false, _retval=0xbfffbeb4) at /home/liu/tmp/b2g/src/embedding/components/windowwatcher/src/nsWindowWatcher.cpp:595
#3  0xb65cf266 in nsWindowWatcher::OpenWindow (this=0xad7640a0, aParent=0xb7ade340, aUrl=0x0, aName=0xbfffbf3c "_blank", aFeatures=0x0, aArguments=0x0, 
    _retval=0xbfffbeb4) at /home/liu/tmp/b2g/src/embedding/components/windowwatcher/src/nsWindowWatcher.cpp:381
#4  0xb623b414 in nsGlobalWindow::OpenInternal (this=0xb7ade340, aUrl=..., aName=..., aOptions=..., aDialog=false, aContentModal=false, aCalledNoScript=true, 
    aDoJSFixups=false, argv=0x0, aExtraArgument=0x0, aCalleePrincipal=0x8dc5be00, aJSCallerContext=0x0, aReturn=0xbfffc100)
    at /home/liu/tmp/b2g/src/dom/base/nsGlobalWindow.cpp:8749
#5  0xb623b91d in nsGlobalWindow::Open (this=0xb7ade340, aUrl=..., aName=..., aOptions=..., _retval=0xbfffc100) at /home/liu/tmp/b2g/src/dom/base/nsGlobalWindow.cpp:5788
#6  0xb65a4ac3 in nsDocShell::InternalLoad (this=0x99575c00, aURI=0x8dd5c1c0, aReferrer=0x97781d70, aOwner=0x8dc5be00, aFlags=0, aWindowTarget=0xbfffc350, 
    aTypeHint=0xbfffc678 "", aPostData=0x0, aHeadersData=0x0, aLoadType=2097153, aSHEntry=0x0, aFirstParty=true, aDocShell=0x0, aRequest=0x0)
    at /home/liu/tmp/b2g/src/docshell/base/nsDocShell.cpp:8267
#7  0xb6595a61 in nsDocShell::OnLinkClickSync (this=0x99575c00, aContent=0x9e640460, aURI=0x8dd5c320, aTargetSpec=0x8d71c768, aPostDataStream=0x0, 
    aHeadersDataStream=0x0, aDocShell=0x0, aRequest=0x0) at /home/liu/tmp/b2g/src/docshell/base/nsDocShell.cpp:11722
#8  0xb6593ecf in OnLinkClickEvent::Run (this=0x8dc2d610) at /home/liu/tmp/b2g/src/docshell/base/nsDocShell.cpp:11526
#9  0xb68dbc56 in nsThread::ProcessNextEvent (this=0xb7a7da00, mayWait=false, result=0xbfffc80f) at /home/liu/tmp/b2g/src/xpcom/threads/nsThread.cpp:624
#10 0xb68aa68c in NS_ProcessNextEvent_P (thread=<optimized out>, mayWait=false) at /home/liu/tmp/b2g/build/xpcom/build/nsThreadUtils.cpp:217
#11 0xb67f6584 in mozilla::ipc::MessagePump::Run (this=0xb2e130a0, aDelegate=0xb7a53830) at /home/liu/tmp/b2g/src/ipc/glue/MessagePump.cpp:82
#12 0xb68ffb56 in MessageLoop::RunInternal (this=0xb7a53830) at /home/liu/tmp/b2g/src/ipc/chromium/src/base/message_loop.cc:208
#13 0xb68ffc7e in RunHandler (this=0xb7a53830) at /home/liu/tmp/b2g/src/ipc/chromium/src/base/message_loop.cc:201
#14 MessageLoop::Run (this=0xb7a53830) at /home/liu/tmp/b2g/src/ipc/chromium/src/base/message_loop.cc:175
#15 0xb673fd48 in nsBaseAppShell::Run (this=0xb026dd30) at /home/liu/tmp/b2g/src/widget/xpwidgets/nsBaseAppShell.cpp:163
#16 0xb6600473 in nsAppStartup::Run (this=0xad7632b0) at /home/liu/tmp/b2g/src/toolkit/components/startup/nsAppStartup.cpp:256
#17 0xb5d23c19 in XREMain::XRE_mainRun (this=0xbfffcad0) at /home/liu/tmp/b2g/src/toolkit/xre/nsAppRunner.cpp:3786
#18 0xb5d23e45 in XREMain::XRE_main (this=0xbfffcad0, argc=3, argv=0xbfffed74, aAppData=0x805ae28) at /home/liu/tmp/b2g/src/toolkit/xre/nsAppRunner.cpp:3863
#19 0xb5d2408a in XRE_main (argc=3, argv=0xbfffed74, aAppData=0x805ae28, aFlags=0) at /home/liu/tmp/b2g/src/toolkit/xre/nsAppRunner.cpp:3939
#20 0x08049d5c in do_main (argv=0xbfffed74, argc=3) at /home/liu/tmp/b2g/src/b2g/app/nsBrowserApp.cpp:153
#21 main (argc=3, argv=0xbfffed74) at /home/liu/tmp/b2g/src/b2g/app/nsBrowserApp.cpp:236



Expected results:

It should go to a new page
(Reporter)

Comment 1

6 years ago
Created attachment 634928 [details]
First click at Backpack
(Reporter)

Comment 2

6 years ago
Created attachment 634929 [details]
Click US$0.99
(Reporter)

Comment 3

6 years ago
Created attachment 634930 [details]
Use browserID log in
(Reporter)

Comment 4

6 years ago
Created attachment 634931 [details]
Click developer button

Comment 5

5 years ago
using whiteboard "b2g-desktop-builds" for ease of tracking
Whiteboard: b2g-desktop-builds
(Reporter)

Comment 6

5 years ago
(In reply to Tony Chung [:tchung] from comment #5)
> using whiteboard "b2g-desktop-builds" for ease of tracking

Tony,

Can you give more detail how should I do ?
(Reporter)

Comment 7

5 years ago
(In reply to Tony Chung [:tchung] from comment #5)
> using whiteboard "b2g-desktop-builds" for ease of tracking

I think I get what you have done.
You have help put "b2g-desktop-builds" in whiteboard field.
Created attachment 651837 [details]
Screengrab for 766574

Screengrab that shows that the bug# 76654 doesn't happen with the latest b2g desktop
(apologize for the size of the attachment)
Attachment #651837 - Attachment description: Screengrab for 76654 → Screengrab for 766574
Comment on attachment 651837 [details]
Screengrab for 766574

Bug does not happen on the latest b2g build (6th August 2012) running on Linux Mint Maya (64-bit) and the latest gaia source

commit 86a470226ce996a6ec627aabe06961880513b65a
Merge: 46410c6 9a12771

This bug could be duplicate of or related to https://bugzilla.mozilla.org/show_bug.cgi?id=782400
(Reporter)

Comment 10

5 years ago
(In reply to Gangadhar Nittala(:gnittala) from comment #9)
> Comment on attachment 651837 [details]
> Screengrab for 766574
> 
> Bug does not happen on the latest b2g build (6th August 2012) running on
> Linux Mint Maya (64-bit) and the latest gaia source
> 
> commit 86a470226ce996a6ec627aabe06961880513b65a
> Merge: 46410c6 9a12771
> 
> This bug could be duplicate of or related to
> https://bugzilla.mozilla.org/show_bug.cgi?id=782400

Confirm here thanks Nittala(:gnittala)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.