All users were logged out of Bugzilla on October 13th, 2018

Character encoding for FCC files not changing to UTF-8

RESOLVED DUPLICATE of bug 238488

Status

()

RESOLVED DUPLICATE of bug 238488
6 years ago
6 years ago

People

(Reporter: cskalyan, Unassigned)

Tracking

13 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 635052 [details]
smpwservices_ja.fcc

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

We have .fcc file with Japanese Characters. In the FCC file, we have set
<HTML>
<HEAD>
    <META http-equiv='Content-Type' content='text/html;charset=utf-8'>
    <TITLE>SiteMinder パスワード サービス</TITLE>


Actual results:

When We try to access the file from Firefox, we see Character encoding as Western(ISO-8859-1) instead of UTF-8. We have IBM HTTP Server 7 as webserver, We did set AddChartype UTF-8 and did  not help. The same page when we access in Internet explorer or chrome, it works fine.


Expected results:

The page should have displayed Japanese characters as expected with encoding set to UTF-8.
(Reporter)

Comment 1

6 years ago
Created attachment 635054 [details]
Attached Screen shot shows, If I change to UTF-8 manually, page gets displayed properly.
Can you please post the http headers for that document?
You can use http://web-sniffer.net if it's a public URL to get the headers or the addon https://addons.mozilla.org/en-US/firefox/addon/live-http-headers/
(Reporter)

Comment 3

6 years ago
https://ftwdsdbg2g31.aig.com:38950/siteminderagent/formsth/smpwservices_ja.fcc?SMAUTHREASON=20

GET /siteminderagent/formsth/smpwservices_ja.fcc?SMAUTHREASON=20 HTTP/1.1
Host: ftwdsdbg2g31.aig.com:38950
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive
Cookie: SMIDENTITY=fuuu+5By/Kh3rVO9CqQW3hUHi3GBRzp8o0b/yK/A3pFhoAA1NTiodE0XTRwnhV/Sn4Ja1VVKjSLcVraOnlTtTTX1+NSa9U3Al+EucMHtKyDCvR4L5Ty2m/UBhtq7yZOWen4PkUzme3S+Ma4JAjueARmV6p9prIg9Q0jjEPEf9cqdpEZiy/P3dIcWElMFnHxsl++bYMmV7PG+DsfXAmKBdq+7DDrdu1K+dru5HlxqVTEzWfrj5v6DBcITdJBtbSU8edYGjw6LQn2A4OuSF2EcyJsMWJeGjW2oi0Fk9Je3cEqnxdCo+bjKdYVdyGjKbhGctxu9QQqKuNr8GPqjbYjpgYEdDeD52WazYULjWzwHNmzRyt3XEngTPmMRQl0GzYkL3bgPP5Uf9aeJV49ReEmxIdyLqD32e+vb17S11eG96SikInEFwZEkvvTF7QyRiZ1bG+U22ObJeHFcOir0Dnm6nnECM5yX7VR/TDwf4Lii/XNQ/yhz/Ss00nLyf8KYO9w50KzdFmB81TZrh2cQSdQDHWURzQfdvRGS9E0LjpxNZ0qOn9vN11EAzwkuFGqW9qnPQzeI4HEn8Bdck/d+AcikQD6jLeClImyTIhkzx0dUHSXfiafn5VM1/RMIREOCy2oq3rN4L64Nrs2CHdgn4jM0gSa+KziHqQcp

HTTP/1.1 200 OK
Date: Thu, 21 Jun 2012 13:53:16 GMT
Server: IBM_HTTP_Server
Cache-Control: no-store
Keep-Alive: timeout=10, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1
----------------------------------------------------------
https://ftwdsdbg2g31.aig.com:38950/siteminderagent/dmspages/netegrity_logo.gif

GET /siteminderagent/dmspages/netegrity_logo.gif HTTP/1.1
Host: ftwdsdbg2g31.aig.com:38950
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Accept: image/png,image/*;q=0.8,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive
Referer: https://ftwdsdbg2g31.aig.com:38950/siteminderagent/formsth/smpwservices_ja.fcc?SMAUTHREASON=20
Cookie: SMIDENTITY=fuuu+5By/Kh3rVO9CqQW3hUHi3GBRzp8o0b/yK/A3pFhoAA1NTiodE0XTRwnhV/Sn4Ja1VVKjSLcVraOnlTtTTX1+NSa9U3Al+EucMHtKyDCvR4L5Ty2m/UBhtq7yZOWen4PkUzme3S+Ma4JAjueARmV6p9prIg9Q0jjEPEf9cqdpEZiy/P3dIcWElMFnHxsl++bYMmV7PG+DsfXAmKBdq+7DDrdu1K+dru5HlxqVTEzWfrj5v6DBcITdJBtbSU8edYGjw6LQn2A4OuSF2EcyJsMWJeGjW2oi0Fk9Je3cEqnxdCo+bjKdYVdyGjKbhGctxu9QQqKuNr8GPqjbYjpgYEdDeD52WazYULjWzwHNmzRyt3XEngTPmMRQl0GzYkL3bgPP5Uf9aeJV49ReEmxIdyLqD32e+vb17S11eG96SikInEFwZEkvvTF7QyRiZ1bG+U22ObJeHFcOir0Dnm6nnECM5yX7VR/TDwf4Lii/XNQ/yhz/Ss00nLyf8KYO9w50KzdFmB81TZrh2cQSdQDHWURzQfdvRGS9E0LjpxNZ0qOn9vN11EAzwkuFGqW9qnPQzeI4HEn8Bdck/d+AcikQD6jLeClImyTIhkzx0dUHSXfiafn5VM1/RMIREOCy2oq3rN4L64Nrs2CHdgn4jM0gSa+KziHqQcp
If-Modified-Since: Wed, 20 Jun 2012 16:20:46 GMT
If-None-Match: "63143-15ca-4c2e9c80afbbd"

HTTP/1.1 404 Not Found
Date: Thu, 21 Jun 2012 13:53:17 GMT
Server: IBM_HTTP_Server
Last-Modified: Wed, 20 Jun 2012 16:20:46 GMT
Etag: "63143-15ca-4c2e9c80afbbd"
Accept-Ranges: bytes
Vary: Accept-Encoding,User-Agent
Content-Encoding: gzip
Content-Length: 1650
Keep-Alive: timeout=10, max=99
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8
----------------------------------------------------------
Is this the request ?
>GET /siteminderagent/formsth/smpwservices_ja.fcc?SMAUTHREASON=20 HTTP/1.1

this is part of the answer from the server:
>Content-Type: text/html; charset=iso-8859-1

A charset header on the http level overrides any charset in the document.
(Reporter)

Comment 5

6 years ago
Yes,GET /siteminderagent/formsth/smpwservices_ja.fcc?SMAUTHREASON=20 HTTP/1.1, is the request.

If A charset header on the http level overrides any charset in the document, then the page is displayed with UTF-8 in Chrome and IE. This issue happens only in Chrome. If I see Character encoding in Chrome/IE for the same page, I see as UTF-8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238488
(Reporter)

Comment 7

6 years ago
Am I Understanding this correctly. This Bug is closed,because it is a duplicate bug of 238488??
Yes that is correct.
bug 238488 is about that a http charset header overrides a charset in the document.
This bug is closed as invalid and that means that your reported issue is no bug.

You have the choice to either remove the charset header in the http response or let the server send a correct utf8 header.
You need to log in before you can comment on or make changes to this bug.