crashed trying to log into hotmail

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: shrir, Assigned: joki)

Tracking

({crash})

Trunk
mozilla0.9.1
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme?, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
seend on 0419 trunk, 

steps:
go to msn.com
on the right, enter username password and click 'GO'

Browser crashes :

 Call Stack:    (Signature = nsEventListenerManager::HandleEvent 0e6f660a) 
     
   nsEventListenerManager::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1057]
     
   nsWindowRoot::HandleChromeEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 188]
     
   GlobalWindowImpl::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 569]
     
   nsXULDocument::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
1931]
     
   nsXULElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3661]
     
   nsXULElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3654]
     
   nsXULElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3654]
     
   nsXULElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3654]
     
   nsXULElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3654]
     
   nsXULElement::HandleChromeEvent 
                                              
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
4631]
     
   GlobalWindowImpl::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 569]
     
   nsDocument::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 2817]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1492]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1486]
     
   nsHTMLFormElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 429]
     
   nsHTMLFormElement::Submit 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 342]
     
   HTMLFormElementSubmit 
                                              
[d:\builds\seamonkey\mozilla\dom\src\html\nsJSHTMLFormElement.cpp, line 427]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 815]
     
   js_Interpret 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2707]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 831]
     
   js_InternalInvoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 903]
     
   JS_CallFunctionValue 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3336]
     
   nsJSContext::CallEventHandler 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 943]
     
   nsJSEventListener::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
     
   nsEventListenerManager::HandleEventSubType 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1034]
     
   nsEventListenerManager::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1590]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1506]
     
   nsHTMLFormElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 429]
     
   nsHTMLFormElement::Submit 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 342]
     
   HTMLFormElementSubmit 
                                              
[d:\builds\seamonkey\mozilla\dom\src\html\nsJSHTMLFormElement.cpp, line 427]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 815]
     
   js_Interpret 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2707]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 831]
     
   js_InternalInvoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 903]
     
   JS_CallFunctionValue 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3336]
     
   nsJSContext::CallEventHandler 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 943]
     
   nsJSEventListener::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
     
   nsEventListenerManager::HandleEventSubType 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1034]
     
   nsEventListenerManager::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1590]
     
   nsGenericElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1506]
     
   nsHTMLFormElement::HandleDOMEvent 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 429]
     
   nsHTMLFormElement::Submit 
                                              
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp, 
line 342]
     
   HTMLFormElementSubmit 
                                              
[d:\builds\seamonkey\mozilla\dom\src\html\nsJSHTMLFormElement.cpp, line 427]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 815]
     
   js_Interpret 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2707]
     
   js_Invoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 831]
     
   js_InternalInvoke 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 903]
     
   JS_CallFunctionValue 
                                              
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3336]
     
   nsJSContext::CallEventHandler 
                                              
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 943]
     
   nsJSEventListener::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
     
   nsEventListenerManager::HandleEventSubType 
                                              
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1034]

Comment 1

18 years ago
Created attachment 31483 [details]
Testcase

Comment 2

18 years ago
Could somebody take a look at the JS code in the testcase??
(Assignee)

Comment 3

18 years ago
I'm not sure if this is event handling based or not.  I don't see a problem on 
the reduced test case but I do on the actual page.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.1

Comment 4

18 years ago
We need a reliable small test case.  Marking qawanted.  Adding nsbeta1+.  We
must, at least, fix the crash for beta.  Is this common?  Why aren't we hearing
from other Hotmail users?

joki may not be the right owner, a better test case is crucial to further progress.
Keywords: nsbeta1 → nsbeta1+, qawanted

Comment 5

18 years ago
I DID got crash when I loaded the testcase into older build (mid-April build).

Now I can't produce the crash using Win32 build 2001050304.  On top of that, I
_can_ login to Hotmail using http://www.msn.com

(Reporter)

Comment 6

18 years ago
i am with doctor_j on this one. cannto seem to repro anymore on 0502 0503 
builds at all.
(Reporter)

Comment 7

18 years ago
update: cannot reproduce on 0509 trunk 
Per comments, marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
verified the bug on 2001-07-07-13-0.9.1 win2000.
Does not occur anymore.
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.