Last Comment Bug 766783 - nsBulletFrame::mComputedSize is unnecessary
: nsBulletFrame::mComputedSize is unnecessary
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on: 78690
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 16:47 PDT by Daniel Holbert [:dholbert]
Modified: 2012-06-22 03:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1 (remove member var) (1.15 KB, patch)
2012-06-20 16:47 PDT, Daniel Holbert [:dholbert]
mats: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-06-20 16:47:20 PDT
Created attachment 635123 [details] [diff] [review]
fix v1 (remove member var)

Just noticed that nsBulletFrame currently has a member variable "mComputedSize" which is unnecessary.

We only use it in one place, and we set its value and then read that value back-to-back in that place.  (I believe this has basically been the case since this variable was added in bug 78690.)

Attached patch just removes the variable altogether.
Comment 1 Mats Palmgren (:mats) 2012-06-20 22:21:59 PDT
Comment on attachment 635123 [details] [diff] [review]
fix v1 (remove member var)

Good catch!
Comment 2 Daniel Holbert [:dholbert] 2012-06-21 13:00:09 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/42c652ac08c8
Comment 3 Ed Morley [:emorley] 2012-06-22 03:45:19 PDT
https://hg.mozilla.org/mozilla-central/rev/42c652ac08c8

Note You need to log in before you can comment on or make changes to this bug.