Closed Bug 766855 Opened 10 years ago Closed 10 years ago

Videos aren't playing on mobile youtube site

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 766914

People

(Reporter: tchung, Unassigned)

Details

now that we're youtube is serving us a mobile site, the video is not playing.   However, if i switch to desktop view, it plays just fine.

See screencast: http://youtu.be/SENUTIfX1T4

Repro:
1) install nightly or 14 beta 7, galaxy nexus 4.0.4
2) goto m.youtube.com, verify you're getting the mobile version
3) search for a video, and tap the play
4) Notice that the video flashes for a second, but then refreshes the page .  video never plays 
5) you can then pan to the bottom of the screen and click "desktop" to switch to desktop youtube
6) verify the desktop site appears, and tapping the video now begins playback.

Expected:
- mobile youtube plays the video, just like desktop youtube

Actual:
- no video playback on mobile youtube
Can someone else confirm on a different device?  nom'ing for blocking if this is true.  We can't serve a youtube page that doesnt playback videos.  I'd rather us serve back the desktop view since playback at least works there.

Nom'ing for triage to access blocking for firefox 14 beta.
(In reply to Tony Chung [:tchung] from comment #1)
> Can someone else confirm on a different device?  nom'ing for blocking if
> this is true.  We can't serve a youtube page that doesnt playback videos. 
> I'd rather us serve back the desktop view since playback at least works
> there.
> 
> Nom'ing for triage to access blocking for firefox 14 beta.

Yeah, I can confirm this to be happening. Strangely enough, this wasn't what I was seeing earlier in the day. Is this really a problem on our end? Or a bad patch by youtube?
blocking-kilimanjaro: --- → ?
(In reply to Jason Smith [:jsmith] from comment #2)
> 
> Yeah, I can confirm this to be happening. Strangely enough, this wasn't what
> I was seeing earlier in the day. Is this really a problem on our end? Or a
> bad patch by youtube?

im guessing youtube's mobile site on FF has a bug.   This works fine with Stock Android (plays video within the page), and Chrome Android (plays video in full screen)
One thing I noticed: On Gingerbread (and Chrome on ICS, I think), the browser hands the video to the YouTube player app. The video is played fullscreen. However, the browser is still displaying the same preview webpage.

This is essentially what Firefox is doing. We re-load the preview page, but never hand the video off to the Youtube player.

Note: I can reproduce this on Firefox desktop using a UA swithcer and setting Fennec's UA.
Duping to bug 766914, which is already marked as blocking Fennec 1.0.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766914
blocking-fennec1.0: ? → ---
blocking-kilimanjaro: ? → ---
tracking it over there.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.