hang if you close mozilla when offline (clean up inbox on exit = ON)

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
MailNews: Backend
P1
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Eric Hedström, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps:
1. log in to an IMAP mail server
2. click the "work offline" widget or File/Work Offline
3. close Mozilla

Result: Mozilla hangs and consumes all the CPU cycles it can

Expected: Mozilla exits.

Updated

17 years ago
QA Contact: esther → gchan

Comment 1

17 years ago
I'm not able to reproduce using apr19 commercial trunk build, win98.
(Reporter)

Comment 2

17 years ago
happens to me on two different win2000sp1 systems, using either Exchange 5.5 or
IMAP-UW as the IMAP server. don't have a win98 system to try it on, though.

I am running "mozilla -mail" if by some chance that's relevant. Using 2001041804
on one system and one a few days old on the other.

Comment 3

17 years ago
I tried it launching to browser then going to mail and also launching -mail. I
tried close, quit, close box. My INBOX is about 2800 messages and the account
has lots of folders.  I tried going offline immediately and waiting awhile.  
(Assignee)

Comment 4

17 years ago
my guess is that Eric has cleanup inbox or empty trash on exit set to true.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 5

17 years ago
Oh, good thinking. I have cleanup inbox on exit turned on.

Comment 6

17 years ago
Yep, that's it. Changed to All platforms.
OS: Windows 2000 → All
Hardware: PC → All
Summary: hang if you close mozilla when offline → hang if you close mozilla when offline (clean up inbox on exit = ON)

Comment 7

17 years ago
either preference (cleanup inbox or empty trash on exit) will cause the hang.  
Strictly imap servers as I checked Pop account settings and set 
(empty trash on exit) pref. It does not hang/crash on Pop accounts when going 
offline and you exit Mozilla.
(Assignee)

Comment 8

17 years ago
Created attachment 31515 [details] [diff] [review]
proposed fix
(Assignee)

Comment 9

17 years ago
the fix is basically to check the rv of CompactFolder, which will be error if
you're offline - I reformatted the whole routine, however, since it was all
horked with tabs.

Comment 10

17 years ago
r=naving

Comment 11

17 years ago
sr=mscott
(Assignee)

Comment 12

17 years ago
nominating.
Keywords: nsbeta1

Updated

17 years ago
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 13

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

17 years ago
looks good! (2001-0427-04 win32-installer on win2k)

Comment 15

17 years ago
BuildID:    2001050304 on WinNT 4.0  2001-05-03-10-trunk/ 

Noticed we still have the problem if we select 
"Empty trash on exit" or select both "Empty trash on exit"
and "Clean up inbox on exit". 

If you select any of those preferences listed above, go offline,
and exit mozila, it will result in a mozilla process running in the
background (use TaskMgr to see it). It appears the program quits
visually but it's still running.

Not sure if you wanted me to "reopen" this bug or create 1 or 2 new
bugs for each additonal case?



(Assignee)

Comment 16

17 years ago
Isn't is just the case that you hang if you have empty trash on exit set and
exit while offline? The rest is irrelevant (i.e., it doesn't matter if you have
cleanup inbox on exit set). Open a new bug on that, please. The fix is not the
same, because the empty trash code does check the return value of the empty
trash command, which the cleanup inbox on exit code was not doing before I fixed it.

Comment 17

17 years ago
Yeah, you're correct David. It's problem with "Empty trash on exit"
pref. It doesn't matter if the trash is empty/full, any other preference
is set, etc.. The bug number for "empty trash on exit" bug is 78825

Comment 18

17 years ago
using 2001052404 build on NT 4.0, 2001052308 build on Linux 2.2, and
2001052408 on Mac OS 9.0.4, I have verified this works.

Steps I did were: 
  Logging into IMAP server
  Setting "Clean up Inbox on Exit" pref
  Go offline
  Quit the program entirely

Tried "mark as deleted" trash mode and that worked to.

No Hang, proces, or noticeable error message appears.

Marking as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.