Unsupported add-ons are migrated as disabled from XUL to Native

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: paul.feher, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [SUMO])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Firefox Mobile 10.0.5 ESR/ Firefox Mozilla Native 14 Migration test build (http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/test14/build1/)
Device: HTC Desire Z (Android 2.3.3), HTC Desire (Android 2.2)

Steps to reproduce:
1. Install Firefox Mobile 10.0.5 ESR from Google Play.
2. Install several add-ons, supported and unsuported by Native Fennec.
3. Download the migration test build (signed Beta build) and install it.
4. Open Firefox and check the add-ons status.

Expected Result:
The user is warned about the possibility that not all add-ons work on native.
Either the unsupported addons are not migrated or the unsupported addons can't be enabled.

Actual Result:
Add-ons that are unsupported are migrated and set disabled but you can activate them.
blocking-fennec1.0: --- → ?
We do not try to move add-ons during a migration. The system knows they are not supported and disables them. It is normal.

My question is: What happens when you try to activate one? Does it attempt to work?

Not a blocker IMO
Created attachment 635820 [details]
logcat

It does try to work, shows as enabled; when you move away from the addons and then go back to it, the addon will show disabled (tested with Xul Personas addon)

Not a blocker IMO as well.
(In reply to Naoki Hirata :nhirata from comment #2)
> Created attachment 635820 [details]
> logcat
> 
> It does try to work, shows as enabled; when you move away from the addons
> and then go back to it, the addon will show disabled (tested with Xul
> Personas addon)
> 
> Not a blocker IMO as well.

This is actually how the current system works. So there isn't really a bug here. We could file a bug to make the Add-on Manager not even allow the user to attempt to enable a non-compatible add-on. The add-on system should be able to tell us that about the add-on.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
blocking-fennec1.0: ? → -
Tagging as SUMO so that Support is aware that this is by design.
Whiteboard: [SUMO]
You need to log in before you can comment on or make changes to this bug.