Issue with viewBox in SVG

RESOLVED INVALID

Status

()

Core
SVG
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: david.dailey, Unassigned)

Tracking

({regression, testcase})

13 Branch
x86_64
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

http://granite.sru.edu/~ddailey/svg/B/BBox0.svg


Actual results:

The positioning of the drawing is different from Chrome, Opera, IE9, and, I am relatively certain, different from earlier versions of FF. 


Expected results:

See behavior in Chrome and Opera (it seems identical). Examine in earlier versions of FF (from say 6-10 months ago when the page was developed)
And if you fix the outer svg element to have height="100%" too?

Comment 2

6 years ago
Created attachment 635355 [details]
SVG fixed with height="100%"

Indeed adding height="100%" fixes the position as previous versions of FF did.

Anyway there is a regression range:

m-c
2011-12-27
2011-12-28
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6f4f2e53694b&tochange=b87861e50640

m-i
2011-12-27
2011-12-28
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e88517446ab2&tochange=2c0351bbc65d

Suspected bug:
966b11b4940d	Jonathan Watt — Bug 668163 - Map 'width' and 'height' on <svg> into style to stop <svg>'s computed width/height falling back to 150px x 300px when they're set to explicit percentage values that can be resolved (regression from bug 611099). r=dbaron.

Updated

6 years ago
Blocks: 668163
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
bug 668163 makes us correctly follow this part of the SVG specification: http://www.w3.org/TR/SVG/coords.html#IntrinsicSizing
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Duplicate of this bug: 787962
Duplicate of this bug: 977578
You need to log in before you can comment on or make changes to this bug.