Create simple test loading content-heavy tabs and switching between them

RESOLVED WONTFIX

Status

Testing Graveyard
Peptest
RESOLVED WONTFIX
6 years ago
3 months ago

People

(Reporter: mcote, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Our current tests aren't that useful in terms of simulating real user actions in which responsiveness is particularly important.

A simple, more appropriate test would be to load a relatively complex page into ten tabs, then measure both the responsiveness when switching between them, and the duration of the switch (from clicking to end of painting).

We should use real pages if possible. We should be able to modify peptest or mozharness to fetch an archive of pages, such as the one talos uses, so that we can load something like Huffington Post, a fairly heavy page.

Comment 1

6 years ago
trying to switch tabs during page loading on 10+ tabs is very bad on firefox. the complete UI sort of hangs. right clicking on tabs, opening the main menu and scrolling on partially loaded tabs is quite slow.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 777817
(Reporter)

Updated

6 years ago
Blocks: 777818
(Reporter)

Comment 3

6 years ago
Looks like we'll probably want to load more than 10 tabs. Correcting summary.
Summary: Create simple test loading 10 tabs and switching between them → Create simple test loading content-heavy tabs and switching between them
(Reporter)

Updated

6 years ago
Depends on: 775547
Created attachment 653493 [details] [diff] [review]
Patch 1.0 - Test tab switching

This test needs tp5n extracted and ready to use. This is available in the build system, but not for normal use, so I'm not sure if this should be checked in to m-c directly or github anyway.
Attachment #653493 - Flags: review?(mcote)
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Created attachment 655717 [details] [diff] [review]
Patch 2.0 - patch against mozilla-central

Since this test can't be run outside of the build system it doesn't make sense to commit it to the github repo. This patch is against mozilla-central.

The test completes successfully: https://tbpl.mozilla.org/?tree=Try&rev=cb4dfbe03fbc&noignore=1
Attachment #653493 - Attachment is obsolete: true
Attachment #653493 - Flags: review?(mcote)
Attachment #655717 - Flags: review?(mcote)
(Reporter)

Comment 6

6 years ago
Comment on attachment 655717 [details] [diff] [review]
Patch 2.0 - patch against mozilla-central

Review of attachment 655717 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, ran fine once I got tp5 all set up.

We should probably disable the other tests, since they have been deemed not-so-useful. I think it's worth keeping them around, though, as examples.

Also a note in the tab-switching test explaining set up (get and extract tp5 to the proper directory) would be useful--because of the way the URLs are structured, this gets lots of 404s when run against the real sites.
Attachment #655717 - Flags: review?(mcote) → review+
Unassigning myself as this is no longer being worked on. I want to leave it open though in case we revisit in the future.
Assignee: ahalberstadt → nobody
Status: ASSIGNED → NEW
Depends on: 784052
No current or future plans for peptest.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

3 months ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.