Guarani - Paraguay | Firefox does not recognize locale gn_PY

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: dellalibera, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 635406 [details]
guarani-spell-checker.xpi

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

I created an addon for spelling of Guaraní, Paraguay. But Firefox does not recognize the locale gn_PY or gn-PY or gug.


Actual results:

I can not find a solution to fix this.


Expected results:

Should have appeared in "check spelling" "Languages ​​-> Guarani / Paraguay"
I'm not familiar enough with spellchecker dictionaries to be sure, but I believe there is a problem with your extension. Guarani [gn] is available in all current builds of Firefox, and I cannot even get your extension to work in my development builds (where I would expect it to). At the very least, there would be a blank entry in the dictionary list.

Kevin, can you confirm that the problem is with the add-on, not Firefox?

Vinícius, I recommend double-checking your work to ensure that you have properly assembled the dictionary. (At first glance, I notice that you don't have an 'aff' file, but I don't know if that is required for the extension to be functional.)
Assignee: registration → nobody
Component: Registration & Management → Internationalization
Product: Mozilla Localizations → Core
QA Contact: registration → i18n

Comment 2

7 years ago
Try adding a dummy affix file.  Works for me with files named xx-YY.dic and xx-YY.aff.
I can confirm that adding an empty 'aff' file fixes the issue. Thus, this is not a bug in Firefox.

A few suggestions:
* Use '-' as a separator in the filenames, not '_'.
* Use 'gn-PY' not 'gug' as the language tag, since Unicode CLDR holds that 'gug' (Paraguayan Guaraní) is the commonest language under macrolanguage 'gn' (Guaraní). (The added region subtag makes that point clear.)
* Add gn-PY.aff, even if it is empty. This will allow the dictionary to be displayed in the appropriate list.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Thanks Gordon!
Resolution: INVALID → WORKSFORME
Summary: Guarani - Paraguay | Firefox does not recognize locale gn_PY → [solved] Guarani - Paraguay | Firefox does not recognize locale gn_PY
Resolution: WORKSFORME → INVALID
Summary: [solved] Guarani - Paraguay | Firefox does not recognize locale gn_PY → Guarani - Paraguay | Firefox does not recognize locale gn_PY
You need to log in before you can comment on or make changes to this bug.