Track which stacks are not moving

RESOLVED DUPLICATE of bug 861863

Status

()

Core
Gecko Profiler
RESOLVED DUPLICATE of bug 861863
5 years ago
4 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
This can be implementing by keeping a bit per label set to 0. When we sample we set all the bits to 1. When we sample next as soon as we see a label with a bit set to 1 we can assume all the children haven't changed.

We can save this in the profile by having a notation to indicate 'copy the base X frames' from the previous sample.

Sadly I don't think we can do anything for stack unwinding.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861863
You need to log in before you can comment on or make changes to this bug.