Last Comment Bug 767162 - New Australis tab design doesn't respect standalone message window
: New Australis tab design doesn't respect standalone message window
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 16.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on: 763308
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 14:37 PDT by Nomis101
Modified: 2012-07-16 08:41 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Wired looking standalone message window (OS X) (36.27 KB, image/jpeg)
2012-06-21 14:37 PDT, Nomis101
no flags Details
patch (3.18 KB, patch)
2012-06-23 00:22 PDT, Richard Marti (:Paenglab)
bugs: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Nomis101 2012-06-21 14:37:04 PDT
Created attachment 635477 [details]
Wired looking standalone message window (OS X)

Bug 763308 has made the tabs looking good, but now the standalone message window looks strange.
Comment 1 Richard Marti (:Paenglab) 2012-06-23 00:22:40 PDT
Created attachment 636041 [details] [diff] [review]
patch

Move the rule from primaryToolbar.css to mailWindow1.css to only work in main window.
Comment 2 Andreas Nilsson (:andreasn) 2012-07-03 07:11:34 PDT
Comment on attachment 636041 [details] [diff] [review]
patch

stealing this from Mike to ease his post-vacation trauma :)
Comment 3 Andreas Nilsson (:andreasn) 2012-07-04 07:22:56 PDT
Comment on attachment 636041 [details] [diff] [review]
patch

Works as expected and is just moving code from one file to another, so r+=me
Comment 4 Richard Marti (:Paenglab) 2012-07-04 07:28:08 PDT
Comment on attachment 636041 [details] [diff] [review]
patch

[Approval Request Comment]
If Bug 763308 becomes approval then this patch should also becoming it to solve the issue on standalone window.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-05 18:43:06 PDT
https://hg.mozilla.org/comm-central/rev/2fffa32b055e
Comment 6 Mark Banner (:standard8, afk until Dec) 2012-07-06 01:45:09 PDT
Due to test failures from bug 755793 landing, I had to back this out:

https://hg.mozilla.org/comm-central/rev/b7dd4a4421e4
Comment 7 Richard Marti (:Paenglab) 2012-07-06 02:12:13 PDT
Asking again for check-in as this patch shouldn't be cause of the failures.
Comment 8 Mike Conley (:mconley) 2012-07-06 06:30:15 PDT
I'm unable to reproduce those failures locally.  I've pushed both this and bug 766793 to try, just in case.

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=140b51b72e6c
Comment 9 Mike Conley (:mconley) 2012-07-06 08:25:36 PDT
Hm, those failures are showing up in the try build. Curious.
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-07-07 07:30:12 PDT
https://hg.mozilla.org/comm-central/rev/9c5bb38d9a0c
Comment 11 Mike Conley (:mconley) 2012-07-16 08:41:51 PDT
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/36dfdbad964e

Note You need to log in before you can comment on or make changes to this bug.