Moving email from IMAP server to local add new line at the end

RESOLVED DUPLICATE of bug 1427732

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 1427732
6 years ago
2 months ago

People

(Reporter: Edoardo Tirtarahardja, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Move an email from IMAP server to local folder.


Actual results:

If you edit message as new (Ctrl+E), you notice that an extra new line is added at the end of the email body.

If you keep moving this message back and forth between IMAP server and local folder, every time it moves to local folder, extra new line is added. So after some time, you can see a bunch of new lines at the end of email body.


Expected results:

A new line should only be added if the message does not end with new line (I think it's an SMTP requirement that a message end with NL).
(Reporter)

Updated

6 years ago
Component: General → Mail Window Front End
(Reporter)

Comment 1

6 years ago
Btw, I think this behavior starts in TB 12 and persisted in TB13.

Comment 2

6 years ago
(In reply to Edoardo Tirtarahardja from comment #0)
Moving the message from IMAP to folder, I get a new line (as you described). Moving the same message back from local to IMAP folder, I get another issue: the message body is truncated (and probably part of the header). Is this another bug?
(Reporter)

Comment 3

6 years ago
I don't have problem moving back to IMAP folder. So either it got to be another bug.

Comment 4

6 years ago
(In reply to Edoardo Tirtarahardja from comment #3)
> I don't have problem moving back to IMAP folder. So either it got to be
> another bug.

I am checking bug 477799 and it seems you need to take an IMAP log: https://wiki.mozilla.org/MailNews:Logging
Component: Mail Window Front End → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend

Comment 5

4 years ago
(In reply to Hashem Masoud from comment #4)
> (In reply to Edoardo Tirtarahardja from comment #3)
> > I don't have problem moving back to IMAP folder. So either it got to be
> > another bug.
> 
> I am checking bug 477799 it seems you need to take an IMAP log:
> https://wiki.mozilla.org/MailNews:Logging

Edoardo, can you do bug 477799 comment 2?

Joe, can you follow up?
Flags: needinfo?(etirta)
(Reporter)

Comment 6

4 years ago
I don't understand about bug 477799 comment 2.

But my problem still exist in TB 24.1.1.

1. Create a draft message on IMAP account, save it (it will be stored in the IMAP draft folder).
2. Move the message (drag it) to a Local folder.
3. Do Ctrl+E on that message in Local folder, you will notice that extra CRLF is added to the new message.
4. Move this message in Local folder *back* to the IMAP draft folder. Dbl click it, you will notice the those extra CRLF that is added in step 2 remain.
5. Move this massage again to a Local folder. and do step 3, you will notice that *more* CRLF are added.
6. If you repeat those steps, you notice that *every time* a message is moved from IMAP draft folder to a Local folder, 1 or 2 CRLF are added.

I understand that SMTP has requirement that a message MUST end with NL, but TB shall check and only add it *only* when it's necessary to add.
Flags: needinfo?(etirta)
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1427732
You need to log in before you can comment on or make changes to this bug.