Can't drag a shortcut into browser

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Drag and Drop
P3
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

(Blocks: 1 bug, {polish, regression})

Trunk
mozilla0.9.2
PowerPC
Mac System 9.x
polish, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
- go to www.mozilla.org
- drag proxy to desktop, proxy created
- go to another page
- drag shortcut from desktop into browser

expected:
- mozilla.org should load

actual:
- nada

something has regressed.
(Assignee)

Updated

17 years ago
Keywords: nsbeta1, nsCatFood, nsmac1, polish, regression

Updated

17 years ago
Blocks: 44267

Comment 1

17 years ago
<blake> pink: will you send me a mac for free, no questions asked?
<pinkerton> no

I don't have a Mac, so not much I can do with this one.  I've got bug 70302 
handling Windows issues.  --> pink, who asked to have this (at least in my mind)
Assignee: blakeross → pinkerton
(Assignee)

Comment 2

17 years ago
--> xpapps
Assignee: pinkerton → pchen
accepting for mozilla0.9.2. P3. 
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Keywords: nsCatFood → nsCatFood-
(Assignee)

Updated

17 years ago
Keywords: nsCatFood- → nsCatFood

Updated

17 years ago
Keywords: nsCatFood → nsCatFood-
(Assignee)

Comment 4

17 years ago
if it's beta1+, it's catfood.
Keywords: nsCatFood- → nsCatFood

Comment 5

17 years ago
nav triage team:

Umm, no, nsbeta1+ != nsCatFood+
Keywords: nsCatFood → nsCatFood-
(Assignee)

Comment 6

17 years ago
yes, this is catfood (because this is important functionality). if we're 
committed to fixing for beta1, why is it 0.9.2?
Keywords: nsCatFood- → nsCatFood

Updated

17 years ago
Keywords: nsCatFood → nsCatFood+

Comment 7

17 years ago
This is also blocking the testing of several other bugs, described in bug 
44267.
(Assignee)

Comment 8

17 years ago
i have a patch. two lines, piece of cake.
Assignee: pchen → pinkerton
(Assignee)

Comment 9

17 years ago
Index: mozilla/xpfe/communicator/resources/content/contentAreaDD.js
===================================================================
RCS file: /m/pub/mozilla/xpfe/communicator/resources/content/contentAreaDD.js,v
retrieving revision 1.18
diff -u -2 -r1.18 contentAreaDD.js
--- contentAreaDD.js	2001/05/12 20:07:12	1.18
+++ contentAreaDD.js	2001/06/04 23:22:17
@@ -191,6 +191,6 @@
     {
       var flavourSet = new FlavourSet();
-      flavourSet.appendFlavour("application/x-moz-file", "nsIFile");
       flavourSet.appendFlavour("text/x-moz-url");
+      flavourSet.appendFlavour("application/x-moz-file", "nsIFile");
       flavourSet.appendFlavour("text/unicode");
       return flavourSet;
Status: NEW → ASSIGNED

Comment 10

17 years ago
[s]r=blake
(Assignee)

Comment 11

17 years ago
Index: mozilla/xpfe/communicator/resources/content/contentAreaDD.js
===================================================================
RCS file: /m/pub/mozilla/xpfe/communicator/resources/content/contentAreaDD.js,v
retrieving revision 1.18
diff -u -2 -r1.18 contentAreaDD.js
--- contentAreaDD.js	2001/05/12 20:07:12	1.18
+++ contentAreaDD.js	2001/06/04 23:29:57
@@ -191,7 +191,7 @@
     {
       var flavourSet = new FlavourSet();
-      flavourSet.appendFlavour("application/x-moz-file", "nsIFile");
       flavourSet.appendFlavour("text/x-moz-url");
       flavourSet.appendFlavour("text/unicode");
+      flavourSet.appendFlavour("application/x-moz-file", "nsIFile");
       return flavourSet;
     },

making files last.

Comment 12

17 years ago
sr=sfraser.
See bug 84063 for a problem about dragging files with a / in the name.

Comment 13

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
(Assignee)

Comment 14

17 years ago
landed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

17 years ago
*** Bug 70302 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Verified on trunk build 2001060508, any chance of landing on branch?
a=blizzard on behalf of drivers for 0.9.1
(Assignee)

Comment 18

17 years ago
landed on brach, 6/5/01, 3:30pm

Comment 19

17 years ago
Verified branch 2001-06-06-03-0.9.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.