If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sync Now force-closes Aurora

RESOLVED DUPLICATE of bug 755794

Status

Android Background Services
Android Sync
RESOLVED DUPLICATE of bug 755794
5 years ago
5 years ago

People

(Reporter: Preetham, Assigned: liuche)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

log
48.34 KB, text/plain
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615064004

Steps to reproduce:

went into firefox sync in account settings. then hit sync now from the menu


Actual results:

aurora force closed


Expected results:

aurora should've synced but it didn't
Hi,

Are you able to reproduce this consistently? If it happens again, can you please capture and attach this bug a log? http://developer.android.com/tools/help/logcat.html
Component: General → Android Sync
OS: Linux → Android
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Hardware: x86 → ARM
Version: Firefox 15 → unspecified
General tips for filing an Android Sync bug:

http://160.twinql.com/how-to-file-a-good-android-sync-bug

If I had to guess, Aurora was taking up a lot of memory, and this was an Out Of Memory exception. A log will tell us.
Summary: sync force closes aurora → Sync Now force-closes Aurora
(Reporter)

Comment 3

5 years ago
Created attachment 635787 [details]
log
(Reporter)

Comment 4

5 years ago
Motorola Defy Plus
Android 2.3.4
fennec-15.0a2.multi.android-arm.apk
last modified: 22-Jun-2012
(In reply to Preetham from comment #3)
> Created attachment 635787 [details]
> log

Thanks so much for the log, super helpful.  It looks like you have both Firefox Aurora and Firefox Beta installed.  Can you verify that?

Unfortunately, we don't yet support having multiple versions of Firefox installed at once -- but we're working on it: Bug 761206.

It also seems like Firefox Beta is successfully syncing.  Can you verify that as well?

Thanks!
sync triage: while more than one fennec installed with sync enabled is not supported in native, this is very concerning behavior. the investigation is a p1.

Preetham, your help is much appreciated.
Assignee: nobody → liuche
Priority: -- → P1
(Reporter)

Comment 7

5 years ago
Yes, I have both installed, and Firefox Beta is syncing successfully. Thank you, you guys have been very helpful.
(Assignee)

Comment 8

5 years ago
I was able to repro by installing an Aurora build on top of the official (signed) Beta build that had Sync already set up.

This is another manifestation of the syncing-multiple-Firefoxes problem, bug 761206. By default, the second instance (Aurora, in this case) will install w/ Sync disabled, but forcing a sync with the Beta SyncAuthenticator will cause the SecurityException and a crash.

There is not much we can do about this that we are not already addressing with bug 761206.
Priority: P1 → --
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755794
(Assignee)

Comment 10

5 years ago
Preetham, we're working to fix this problem in a later release, but basically you will be able to sync either Aurora or Beta, but not both. If you want to sync Aurora, uninstall Beta, and then Aurora will automatically start syncing your data that you had in Beta.

Also, you can see this document for more specific reasons, if you're interested: https://wiki.mozilla.org/User:Anaaktgeboren/NativeSync#Android_Sync_behavior_with_multiple_Firefox_versions_installed
(Reporter)

Comment 11

5 years ago
Thank you.
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.